Reply To: Outbound calls to operator do not work

VitalPBX Community Support General Discussion Outbound calls to operator do not work Reply To: Outbound calls to operator do not work

    Daman
    Participant
    Up
    0
    Down
    Outbound routes works fine now. The problem was something to do with the PSTN number they gave me. With another number outbound calls just works fine.

    But now still inbound do not work. I can see from the sngrep log that the call is coming in but it do not connect to my SNOM phones. When I call internal call from SNOM to another it works perfectly. When I make outbound call it works now fine. But inbound calls from PSTN do not work.

    I have installed to one of my windows computers for testing the line a program called phonerline and it works well both inbound and outbound and the system is inside the same subnet and therefore it is not about the line. It is something with my vitalpbx setup. I just cannot figure out why the phones do not ring.

    I have tested with inbound destination one extension (SNOM which works outbound and internal calls fine) and with ring group (all SNOMs). Call do not work. When I try to call to my number from PTSN the voice says “The dialed number is incorrect”. But the number is fine and working.

    Inbound routes are as follows:

    Routing method:   Default

    Description:  123456789  (same as my DID pattern)

    DID pattern:  123456789  (my phone number in an international form without +)

    CID pattern:        (nothing)

    CID Modifier:  None

    CID lookup:  None

    Trunks (Device for incoming calls / User)

    User name:  x.x.x.x   (IP that was given to my by my PSTN)

    Host:  x.x.x.x   (same as previous)

    IP authentication: Yes

    Quality:  Yes

    Again, now everything works but this inbound route meaning that the phones do not even ring and the bot says that the number is incorrect. But it is not because phoneline works both in and out with the same number/PSTN/setup, and outbound works well.

    One hint may be that with incoming call the second line in the sngrep says that “484 Address Incomplete”. I tried to find a solution based on that 484 but I cannot found anything that helps.

    0