Reply To: RE: +8888 problem grandstream

VitalPBX Community Support General Discussion +8888 problem grandstream Reply To: RE: +8888 problem grandstream

    Check what SIP profile is assigned to your tunks, I assume is the default profile. You may try two options:

    1. If you have the latest VitalPBX version, you may go to your trunk and set the Technology profile to none
    2. You may go to the trunk assigned profile and change the Send/Trust Remote Party ID fields to no

    Why does this happen?

    If you set “trustrpid=yes” in the definition of the source peer in sip.conf, then Asterisk will copy the number from the RPI header (instead of the From header) of the request is received on the inbound call leg.

    According to the above definition, basically means, that when the provider receives the call invite, it adds +8888 on the Remote-Party-ID headers, so, due the trustrpid parameter is enabled, then, the phone shows, what is received on this header, on this case, +888832496xxxxxx.

     

    0