Reply To: RE: Behind firewall no audio either way

VitalPBX Community Support General Discussion Behind firewall no audio either way Reply To: RE: Behind firewall no audio either way

    phil
    Participant
    Up
    0
    Down

    ok, it could be the vitalpbx firewall under security – disable that on the same network.

    then allow tcp/udp 5060 from your sip trunk public ip to your firewall and port forward to vitalpbx. then allow world to udp 10000-20000 to firewall which is forwarded to your pbx.

    this ensures sip the connection control can only be setup by your local phones and also through the trunk. the rtp connection can then be handed off to any ip.

    if you have a trunk that has several ip’s they must all be in the firewall and forwarded to the pbx

    Settings:sip settings:network

    I have the NAT entry NAT as force and the external IP as the public IP of the PBX/phones lan

    Local networks i have the private ip of the pbx/phone lan eg: 192.168.1.0 

     

    try that 🙂

    0