Reply To: RE: Behind firewall no audio either way

VitalPBX Community Support General Discussion Behind firewall no audio either way Reply To: RE: Behind firewall no audio either way

    phil
    Participant

    Trent,

    The peer report will show the ip of the local lan if the pbx is on this, if the pbx is remotely hosted then it will show the wan ip of your firewall.

    Stun server does nothing magical except get your public wan ip which is great if you have a dynamic address.

    Its possible that your phones config is now incorrect – the sip server is the pbx ip of your lan. The rtp ports on your phone should also have a start port or a range this should start at 10000 or range 10000-20000.

    99% audio issues are RTP ports or firewall – disable the vitalpbx firewall as its on your lan behind your main router/firewall and double natting can be a problem.

     

    Yealink:
    The Local SIP Port setting will be found in the settings of most Yealinks under Account –> Advanced or under Settings –> SIP.
    Your Yealink’s Local RTP Ports will be found under Network –> Advanced
     
    You can test using the *70 date/time *72/echo
     
    Sounds like you are getting close – one way audio outbound seems simpler because the connection is being established by you, but when the inbound audio comes in on rtp, it either has the wrong ip (eg its using private instead of public or vice versa) or it has the right ip but the wrong port.
     
    This is where connecting now to the vitalpbx server console with ssh and running a debug on the sip will show the setup of the call and then when the data comes in what happens.
     
    If this is still not working I will take some screen shots of my setup, I have both a local same lan PBX and an AWS PBX with a single phone – two different trunks for each PBX and once its mapped out, it does work well. I use pfsense firewall with *no* siproxy and just port forwarding for my local PBX.
     
    LMK
    Phil
     
    0