Reply To: RE: Fax Module issues

VitalPBX Community Support General Discussion Fax Module issues Reply To: RE: Fax Module issues

    pftech-pf
    Participant

    Hi there,

    I’ve updated VitalPBX to 2.3.8-1 

    But I cannot update VirtualFax 1.0.3-1 because everytime I try to do the upgrade through the webUI I get this error message:

    Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: centos.crazyfrogs.org * epel: mirror.netweaver.uk * extras: centos.quelquesmots.fr * updates: centos.quelquesmots.fr Resolving Dependencies --> Running transaction check ---> Package vitalpbx-virtual-faxes.x86_64 0:1.0.2-1 will be updated ---> Package vitalpbx-virtual-faxes.x86_64 0:1.0.3-1 will be an update --> Processing Dependency: ghostscript = 9.07 for package: vitalpbx-virtual-faxes-1.0.3-1.x86_64 --> Finished Dependency Resolution Error: Package: vitalpbx-virtual-faxes-1.0.3-1.x86_64 (vpbx-addons) Requires: ghostscript = 9.07 Installed: ghostscript-9.25-2.el7_7.2.x86_64 (@updates) ghostscript = 9.25-2.el7_7.2 Available: ghostscript-9.25-2.el7.i686 (base) ghostscript = 9.25-2.el7 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest


    Then if I try to do the update via ssh through the console using yum update, I get this error:

    yum install vitalpbx-virtual-faxes-1.0.3-1.x86_64
    Plugin abilitati:fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.crazyfrogs.org
    * epel: fr2.rpmfind.net
    * extras: centos.quelquesmots.fr
    * updates: mirrors.ircam.fr
    Risoluzione dipendenze
    --> Esecuzione del controllo di transazione
    ---> Pacchetto vitalpbx-virtual-faxes.x86_64 0:1.0.3-1 settato per essere installato
    --> Elaborazione dipendenza: ghostscript = 9.07 per il pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64
    --> Elaborazione dipendenza: hylafax+ >= 5.6.1 per il pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64
    --> Esecuzione del controllo di transazione
    ---> Pacchetto hylafax+.x86_64 0:7.0.0-1.el7 settato per essere installato
    --> Elaborazione dipendenza: ghostscript per il pacchetto: hylafax+-7.0.0-1.el7.x86_64
    ---> Pacchetto vitalpbx-virtual-faxes.x86_64 0:1.0.3-1 settato per essere installato
    --> Elaborazione dipendenza: ghostscript = 9.07 per il pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64
    --> Esecuzione del controllo di transazione
    ---> Pacchetto ghostscript.x86_64 0:9.25-2.el7_7.2 settato per essere installato
    ---> Pacchetto vitalpbx-virtual-faxes.x86_64 0:1.0.3-1 settato per essere installato
    --> Elaborazione dipendenza: ghostscript = 9.07 per il pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64
    --> Risoluzione delle dipendenze completata
    Errore: Pacchetto: vitalpbx-virtual-faxes-1.0.3-1.x86_64 (vpbx-addons)
    Richiede: ghostscript = 9.07
    Disponibile: ghostscript-9.25-2.el7.i686 (base)
    ghostscript = 9.25-2.el7
    Disponibile: ghostscript-9.25-2.el7_7.2.i686 (updates)
    ghostscript = 9.25-2.el7_7.2
    Si può provare ad usare --skip-broken per aggirare il problema
    Provare ad eseguire: rpm -Va --nofiles --nodigest

    (sorry for italian language console)

     

    Tried also to remove ghostscript and hylafax without success.

     

    Best regards,

    Paolo

    0