Reply To: RE: Google TTS Tutorial

VitalPBX Community Support General Discussion Google TTS Tutorial Reply To: RE: Google TTS Tutorial

    Antonio
    Participant

    Hi

    Now it´s clear that is two different applications, the TTS and ASR. I’ve installed the TTS, after it I installed ASR (both by script), and now it´s working the *277 test. But the *2770 isn´t working. Stay asking to repeat the number, I said different numbers and the system isn´t recognizing. See below the log:

     

    — Executing [*2770@T10_cos-all:1] Answer(“SIP/T10_1211-000010e5”, “”) in new stack
    > 0x7efd008bea10 — Strict RTP qualifying stream type: audio
    > 0x7efd008bea10 — Strict RTP switching source address to X.X.X.X:13200
    — Executing [*2770@T10_cos-all:2] AGI(“SIP/T10_1211-000010e5”, “googletts.agi,”PLease say the number you want to dial.”,en”) in new stack
    — Launched AGI Script /var/lib/asterisk/agi-bin/googletts.agi
    — <SIP/T10_1211-000010e5> Playing ‘/tmp/6ec1e92493ec4fcce8e67e3f293b125b.slin’ (escape_digits=) (sample_offset 0) (language ‘en’)
    — <SIP/T10_1211-000010e5>AGI Script googletts.agi completed, returning 0
    — Executing [*2770@T10_cos-all:3] AGI(“SIP/T10_1211-000010e5”, “googleasr.agi,en-US”) in new stack
    — Launched AGI Script /var/lib/asterisk/agi-bin/googleasr.agi
    — <SIP/T10_1211-000010e5> Playing ‘beep.ulaw’ (language ‘en’)
    > 0x7efd008bea10 — Strict RTP learning complete – Locking on source address X.X.X.X:13200
    — <SIP/T10_1211-000010e5>AGI Script googleasr.agi completed, returning 0
    — Executing [*2770@T10_cos-all:4] GotoIf(“SIP/T10_1211-000010e5”, “0?success:retry”) in new stack
    — Goto (T10_cos-all,*2770,6)
    — Executing [*2770@T10_cos-all:6] AGI(“SIP/T10_1211-000010e5”, “googletts.agi,”Can you please repeat?”,en”) in new stack
    — Launched AGI Script /var/lib/asterisk/agi-bin/googletts.agi
    — <SIP/T10_1211-000010e5> Playing ‘/tmp/b70a2b4f0891b80fb0211747e1f0fc78.slin’ (escape_digits=) (sample_offset 0) (language ‘en’)
    — <SIP/T10_1211-000010e5>AGI Script googletts.agi completed, returning 0
    — Executing [*2770@T10_cos-all:7] Goto(“SIP/T10_1211-000010e5”, “record”) in new stack
    — Goto (T10_cos-all,*2770,3)
    — Executing [*2770@T10_cos-all:3] AGI(“SIP/T10_1211-000010e5”, “googleasr.agi,en-US”) in new stack
    — Launched AGI Script /var/lib/asterisk/agi-bin/googleasr.agi
    — <SIP/T10_1211-000010e5> Playing ‘beep.ulaw’ (language ‘en’)

    I saved my Google API key in the googleasr.agi file.

    0