Reply To: RE: Sonata Switchboard License Issue?

VitalPBX Community Support General Discussion Sonata Switchboard License Issue? Reply To: RE: Sonata Switchboard License Issue?

    krzykat
    Participant

    OK – I know why we’re having an issue.  To lock down our server and force people to use FQDN, we changed our httpd conf.d to:

    <VirtualHost *:80>
    ServerName default
    DocumentRoot /usr/share/ombutel/www/err
    <Directory “/usr/share/ombutel/www/err”>
    Require all granted
    </Directory>
    </VirtualHost>

    <VirtualHost *:80>
    UseCanonicalName Off
    ServerName phone.ourserver.com
    DocumentRoot /usr/share/ombutel/www
    <Directory “/usr/share/ombutel/www”>
    Require all granted
    Options FollowSymlinks
    AllowOverride all
    </Directory>
    <Directory “/var/lib/ombutel/static”>
    Require all granted
    </Directory>
    <Directory “/var/spool/asterisk/monitor”>
    Require all granted
    </Directory>
    Alias /static “/var/lib/ombutel/static”
    Alias /api/v2 “/usr/share/ombutel/www/api_v2.php”
    Alias /api “/usr/share/ombutel/www/api.php”
    Alias /monitor “/var/spool/asterisk/monitor”
    AliasMatch “^/modules/dahdi_hardware/xorcom_device[0-9]+.png$” “/usr/share/ombutel/www/modules/dahdi_hardware/xorcom_device.php”
    AliasMatch “^/modules/fax/preview_coversheet$” “/usr/share/ombutel/www/modules/fax/preview_coversheet.php”
    AliasMatch “^/resources/css/branding.css$” “/usr/share/ombutel/www/branding.php”

    </VirtualHost>

    <VirtualHost *:443>
    SSLEngine On
    SSLCertificateFile /etc/pki/tls/certs/localhost.crt
    SSLCertificateKeyFile /etc/pki/tls/private/localhost.key

    UseCanonicalName Off
    DocumentRoot /usr/share/ombutel/www
    <Directory “/usr/share/ombutel/www”>
    Require all granted
    Options FollowSymlinks
    AllowOverride all
    </Directory>
    <Directory “/var/lib/ombutel/static”>
    Require all granted
    </Directory>
    <Directory “/var/spool/asterisk/monitor”>
    Require all granted
    </Directory>
    Alias /static “/var/lib/ombutel/static”
    Alias /api/v2 “/usr/share/ombutel/www/api_v2.php”
    Alias /api “/usr/share/ombutel/www/api.php”
    Alias /monitor “/var/spool/asterisk/monitor”
    AliasMatch “^/modules/dahdi_hardware/xorcom_device[0-9]+.png$” “/usr/share/ombutel/www/modules/dahdi_hardware/xorcom_device.php”
    AliasMatch “^/modules/fax/preview_coversheet$” “/usr/share/ombutel/www/modules/fax/preview_coversheet.php”
    AliasMatch “^/resources/css/branding.css$” “/usr/share/ombutel/www/branding.php”
    </VirtualHost>

     

    With this change to force users to use phone.ourcompany.com vitalPBX works fine, but the switchboard does not.  Advice ??

    0