Apache is broken after update to vitalpbx-2.4.0-1

VitalPBX Community Support General Discussion Apache is broken after update to vitalpbx-2.4.0-1

  • Post
    lmoreira
    Participant

    After upgrade to vitalpbx-2.4.0-1, apache stops and  dosent restart.

    Tested on several servers. Anyone got the same problem?

    # service httpd status
    Redirecting to /bin/systemctl status httpd.service
    ● httpd.service - The Apache HTTP Server
    Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
    Active: failed (Result: exit-code) since Seg 2019-12-16 11:34:00 -03; 2min 16s ago
    Docs: man:httpd(8)
    man:apachectl(8)
    Main PID: 32118 (code=exited, status=1/FAILURE)

    Dez 16 11:34:00 localhost systemd[1]: Starting The Apache HTTP Server...
    Dez 16 11:34:00 localhost systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
    Dez 16 11:34:00 localhost kill[32119]: kill: cannot find process ""
    Dez 16 11:34:00 localhost systemd[1]: httpd.service: control process exited, code=exited status=1
    Dez 16 11:34:00 localhost systemd[1]: Failed to start The Apache HTTP Server.
    Dez 16 11:34:00 localhost systemd[1]: Unit httpd.service entered failed state.
    Dez 16 11:34:00 localhost systemd[1]: httpd.service failed.
    Dez 16 11:35:46 localhost systemd[1]: Unit httpd.service cannot be reloaded because it is inactive.
    Dez 16 11:35:46 localhost systemd[1]: Unit httpd.service cannot be reloaded because it is inactive.
    0
Viewing 8 replies - 1 through 8 (of 8 total)
  • Replies
    Up
    0
    Down

    May you post the error log of the httpd service:

    cat /var/log/httpd/error_log

    0
    lmoreira
    Participant
    Up
    0
    Down
    [Sun Dec 15 03:30:02.781948 2019] [lbmethod_heartbeat:notice] [pid 7053] AH02282: No slotmem from mod_heartmonitor
    [Sun Dec 15 03:30:02.783891 2019] [ssl:emerg] [pid 7053] AH02238: Unable to configure RSA server private key
    [Sun Dec 15 03:30:02.783921 2019] [ssl:emerg] [pid 7053] SSL Library Error: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
    [Sun Dec 15 03:30:02.783925 2019] [ssl:emerg] [pid 7053] AH02312: Fatal error initialising mod_ssl, exiting.
    [Mon Dec 16 11:34:00.104360 2019] [suexec:notice] [pid 32118] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Mon Dec 16 11:34:00.106427 2019] [ssl:emerg] [pid 32118] AH02238: Unable to configure RSA server private key
    [Mon Dec 16 11:34:00.106447 2019] [ssl:emerg] [pid 32118] SSL Library Error: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
    [Mon Dec 16 11:34:00.106450 2019] [ssl:emerg] [pid 32118] AH02312: Fatal error initialising mod_ssl, exiting.
    [Mon Dec 16 11:36:20.438519 2019] [suexec:notice] [pid 632] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Mon Dec 16 11:36:20.439713 2019] [ssl:emerg] [pid 632] AH02238: Unable to configure RSA server private key
    [Mon Dec 16 11:36:20.439741 2019] [ssl:emerg] [pid 632] SSL Library Error: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
    [Mon Dec 16 11:36:20.439745 2019] [ssl:emerg] [pid 632] AH02312: Fatal error initialising mod_ssl, exiting.
    0
    Up
    0
    Down

    Are you using let’s encrypt certificates?

    0
    lmoreira
    Participant
    Up
    0
    Down

    Yes. I am.

     
    0
    Up
    0
    Down

    Looks like your certificate for some reasons has been marked as invalid, so, try this for fix it:

    #Regenerate the let's encrypt certificate
    /usr/share/ombutel/scripts/lets_encrypt
    #Reconfigure Apache
    /usr/share/ombutel/scripts/apache_conf
    #Restart the HTTPD service
    systemctl restart httpd
    0
    lmoreira
    Participant
    Up
    0
    Down
    Posted by: @ing-joserivera26

    #Regenerate the let’s encrypt certificate
    /usr/share/ombutel/scripts/lets_encrypt
    #Reconfigure Apache
    /usr/share/ombutel/scripts/apache_conf
    #Restart the HTTPD service
    systemctl restart httpd

    Apache stills broken after apply this commands.

    Any way to revert lets_encript and let apache run without it?

    0
    Up
    0
    Down

    For reset to the default configurations do the following:

    #Reset Configurations
    mysql -uroot ombutel -e"update ombu_settings set value = null where module_id = (select module_id from ombu_modules where name = 'http_server') and name = 'certificate_id';"
    mysql -uroot ombutel -e"update ombu_settings set value = 'no' where module_id = (select module_id from ombu_modules where name = 'http_server') and name = 'permanent_redirect';"

    #Reconfigure Apache and Restart
    /usr/share/ombutel/scripts/apache_conf
    systemctl restart httpd
    0
    lmoreira
    Participant
    Up
    0
    Down
    Posted by: @ing-joserivera26

    For reset to the default configurations do the following:

    #Reset Configurations
    mysql -uroot ombutel -e"update ombu_settings set value = null where module_id = (select module_id from ombu_modules where name = 'http_server') and name = 'certificate_id';"
    mysql -uroot ombutel -e"update ombu_settings set value = 'no' where module_id = (select module_id from ombu_modules where name = 'http_server') and name = 'permanent_redirect';"

    #Reconfigure Apache and Restart
    /usr/share/ombutel/scripts/apache_conf
    systemctl restart httpd

    Thanks!!! That solved the problem!

    0
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Apache is broken after update to vitalpbx-2.4.0-1’ is closed to new replies.