Apache is down after installing browser phone from blog post

VitalPBX Community Support General Discussion Apache is down after installing browser phone from blog post

  • Post
    Gary
    Participant
    Up
    1
    Down
    I followed instruction in recent blog post for the Browser-Phone, Apache will no longer start, before I installed this the WebRTC phone was working with Vitxi.

    [root@vitalpbx3 ~]# systemctl restart httpd
    Job for httpd.service failed because the control process exited with error code. See “systemctl status httpd.service” and “journalctl -xe” for details.
    [root@vitalpbx3 ~]# systemctl status httpd.service
    ● httpd.service – The Apache HTTP Server
    Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
    Active: failed (Result: exit-code) since Fri 2021-02-26 16:15:02 EST; 11s ago
    Docs: man:httpd(8)
    man:apachectl(8)
    Process: 27696 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=0/SUCCESS)
    Process: 14964 ExecReload=/usr/sbin/httpd $OPTIONS -k graceful (code=exited, status=0/SUCCESS)
    Process: 27838 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
    Main PID: 27838 (code=exited, status=1/FAILURE)

    Feb 26 16:15:02 vitalpbx3 systemd[1]: Starting The Apache HTTP Server…
    Feb 26 16:15:02 vitalpbx3 httpd[27838]: AH00526: Syntax error on line 7 of /etc/httpd/conf.d/webrtc_phone.conf:
    Feb 26 16:15:02 vitalpbx3 httpd[27838]: Header has too many arguments
    Feb 26 16:15:02 vitalpbx3 systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
    Feb 26 16:15:02 vitalpbx3 systemd[1]: Failed to start The Apache HTTP Server.
    Feb 26 16:15:02 vitalpbx3 systemd[1]: Unit httpd.service entered failed state.
    Feb 26 16:15:02 vitalpbx3 systemd[1]: httpd.service failed.

     

    0
Viewing 9 replies - 1 through 9 (of 9 total)
  • Replies
    Gary
    Participant
    Up
    0
    Down
    I think this is a typo, Header ser Expires: 0 I changed to Header set Expires: 0 but it still doesn’t start.
    0
    Maynor Peralta
    Keymaster
    US
    Up
    0
    Down
    Hello Sir.,

    You can send a screenshot of the configuration file /etc/httpd/conf.d/webrtc_phone.conf

    Best regards!

    0
    Gary
    Participant
    Up
    0
    Down
    I changed set on line 8 and removed spaces on line 7 and it now starts so I can see main gui, I will check to se if the browser-phone works.

    Alias /Browser-Phone/Phone /usr/share/webrtc/Browser-Phone/Phone
    Alias /Phone /usr/share/webrtc/Browser-Phone/Phone
    <Directory “/usr/share/webrtc/Browser-Phone/Phone”>
    AddDefaultCharset UTF-8
    php_value magic_quotes_gpc off
    <Files *>
    Header set Cache-Control: “private,pre-check=0,post-check=0,max-age=0”
    Header set Expires: 0
    Header set Pragma: no-cache
    </Files>
    Require all granted
    AllowOverride all
    Options +FollowSymLinks
    </Directory>

    0
    Gary
    Participant
    Up
    0
    Down
    I can not access browser phone url.

    Forbidden
    You don’t have permission to access /Browser-Phone/Phone on this server.

     

    [root@vitalpbx3 webrtc]# ls -l
    total 4
    drwxr-xr-x 7 apache apache 4096 Feb 26 16:13 Browser-Phone
    [root@vitalpbx3 webrtc]#

    0
    Gary
    Participant
    Up
    0
    Down
    Is there something I missed.

    Alias /Browser-Phone/Phone /usr/share/webrtc/Browser-Phone/Phone
    Alias /Phone /usr/share/webrtc/Browser-Phone/Phone
    <Directory “/usr/share/webrtc/Browser-Phone/Phone”>
    AddDefaultCharset UTF-8
    php_value magic_quotes_gpc off
    <Files *>
    Header set Cache-Control: “private, pre-check=0, post-check=0, max-age=0”
    Header set Expires: 0
    Header set Pragma: no-cache
    </Files>
    Require all granted
    AllowOverride all
    Options +FollowSymLinks
    </Directory>

     

     

    Attachments:
    You must be logged in to view attached files.
    0
    Maynor Peralta
    Keymaster
    US
    Up
    1
    Down
    Hello Sir.,

    Check that the site folder has the apache owner assigned, otherwise run the following command:

    chown -R apache: apache /usr/share/webrtc/

    Then try to enter the site,

    Best regards!

    1
    Gary
    Participant
    Up
    0
    Down
    It is assigned to apache

    drwxr-xr-x 3 apache apache 4096 Feb 26 16:13 webrtc

    Can this work on a system that also has webrtc vitxi, that is working on this server.

    Is there any port that the browser phone needs different to what the webrtc/vitxi is using

    0
    Gary
    Participant
    Up
    1
    Down
    Used new settings in blog post and Browser Phone is now working.

    Thanks,

     

    1
    Rodrigo Cuadra
    Keymaster
    US
    Up
    0
    Down
    Gary:

    We are very sorry for the inconvenience. The problem was that in the Apache file configuration the double quotes were not in the proper format.

    0
Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.