Call Center Queue

VitalPBX Community Support General Discussion Call Center Queue

  • Post
    Zia UrRehman
    Participant

    Dear Community .

    Actually i have one issue in VitalPBX queue. When multiple call reach to Queue at same time so Just one call hit queue agent and the remaining call still in queue even there free agents. I check all Strategy option but no luck.

    I am using VitalPBX 2.3.3-1

     

    Following is Queue config:

     

    [Q199]
    strategy=rrmemory
    musicclass=ringback
    autofill=no
    maxlen=0
    periodic-announce=/var/lib/ombutel/static/8c6785d40f7e83ba/recordings/c81e728d9d4c2f636f067f89cc14862c
    wrapuptime=0
    announce-frequency=0
    min-announce-frequency=0
    periodic-announce-frequency=3600
    announce-round-seconds=0
    announce-to-first-user=no
    announce-position=no
    relative-periodic-announce=no
    announce-holdtime=no
    autopause=no
    ringinuse=no
    timeoutrestart=no
    joinempty=yes
    timeoutpriority=app
    timeout=30
    leavewhenempty=no
    retry=5
    member=>Local/121@queue-call-to-agents,0,121,hint:121@extension-hints,no
    member=>Local/122@queue-call-to-agents,0,122,hint:122@extension-hints,no
    member=>Local/123@queue-call-to-agents,0,123,hint:123@extension-hints,no
    member=>Local/124@queue-call-to-agents,0,124,hint:124@extension-hints,no
    member=>Local/125@queue-call-to-agents,0,125,hint:125@extension-hints,no
    member=>Local/126@queue-call-to-agents,0,126,hint:126@extension-hints,no
    member=>Local/127@queue-call-to-agents,0,127,hint:127@extension-hints,no
    member=>Local/128@queue-call-to-agents,0,128,hint:128@extension-hints,no
    member=>Local/129@queue-call-to-agents,0,129,hint:129@extension-hints,no
    member=>Local/130@queue-call-to-agents,0,130,hint:130@extension-hints,no

     

     

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • Replies
    Up
    0
    Down

    You may check the status of the queue agents:

    queue show Q199

    0
    Zia UrRehman
    Participant
    Up
    0
    Down

    vitalpbx*CLI> queue show Q199
    Q199 has 0 calls (max unlimited) in ‘random’ strategy (19s holdtime, 50s talktime), W:0, C:7, A:3, SL:0.0%, SL2:0.0% within 0s
    Members:
    130 (Local/130@queue-call-to-agents from hint:130@extension-hints) (ringinuse disabled) (Busy) has taken no calls yet
    129 (Local/129@queue-call-to-agents from hint:129@extension-hints) (ringinuse disabled) (Not in use) has taken no calls yet
    128 (Local/128@queue-call-to-agents from hint:128@extension-hints) (ringinuse disabled) (Busy) has taken no calls yet
    127 (Local/127@queue-call-to-agents from hint:127@extension-hints) (ringinuse disabled) (Busy) has taken no calls yet
    126 (Local/126@queue-call-to-agents from hint:126@extension-hints) (ringinuse disabled) (Busy) has taken no calls yet
    125 (Local/125@queue-call-to-agents from hint:125@extension-hints) (ringinuse disabled) (Not in use) has taken no calls yet
    124 (Local/124@queue-call-to-agents from hint:124@extension-hints) (ringinuse disabled) (Not in use) has taken no calls yet
    123 (Local/123@queue-call-to-agents from hint:123@extension-hints) (ringinuse disabled) (in call) (In use) has taken no calls yet
    122 (Local/122@queue-call-to-agents from hint:122@extension-hints) (ringinuse disabled) (Busy) has taken no calls yet
    121 (Local/121@queue-call-to-agents from hint:121@extension-hints) (ringinuse disabled) (Busy) has taken no calls yet
    No Callers

    0
    Up
    0
    Down

    There are various agents marked as busy, I assume that they are on call.

    you may try to regenerate asterisk configurations, executing the following command in Linux console:

    vitalpbx --dump-conf

    asterisk -rx"core reload"
    0
    Zia UrRehman
    Participant
    Up
    0
    Down

    Dear Sir .
    please check the snapshot.

    1st call is hit agent while remaining call still in queue even there are free agents 

    0
    Zia UrRehman
    Participant
    Up
    0
    Down

    Sir i applied command but still same output by using “queue show Q199” 

     

    0
    Up
    0
    Down

    Did you try the commands above?

    Did you also update Sonata Switchboard to the latest version?

    0
    Zia UrRehman
    Participant
    Up
    0
    Down

    Yes i used above command as well, while both VitalPBX and Sonata Switchboard are updated  to latest version

    0
    Up
    0
    Down

    Change the value of Autofill parameter to yes

    0
    Up
    0
    Down

    AutoFill Behavior
    The old behavior of the queue (autofill=no) is to have a serial type behavior in that the queue will make all waiting callers wait in the queue even if there is more than one available member ready to take calls until the head caller is connected with the member they were trying to get to. The next waiting caller in line then becomes the head caller, and they are then connected with the next available member and all available members and waiting for callers waits while this happens.

    The new behavior, enabled by setting autofill=yes makes sure that when the waiting callers are connecting with available members in a parallel fashion until there are no more available members or no more waiting callers. This is probably more along the lines of how a queue should work and in most cases, you will want to enable this behavior.

    0
    Zia UrRehman
    Participant
    Up
    0
    Down

    Done….
    “Autofill parameter: Yes”
    thanks for you kind support and save my life. 

    Really Appreciated.
     

    0
    Up
    0
    Down

    You’re welcome.

    Don’t forget to check our amazing VitalPBX Plans and our store

    0
    Zia UrRehman
    Participant
    Up
    0
    Down

    sure sir

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.