Call immediately disconnected. – Fresh install

VitalPBX Community Support General Discussion Call immediately disconnected. – Fresh install

  • Post
    Syirrus
    Participant

    Hey guys, 

    I just installed vitalpbx on a digitalocean.  I setup two extensions: 101 and 102.

    I setup up my sip devices, and they login successfully.

    However, when I try to place a call from either sip device, it connects and immediately disconnects.

    Here is something I found in my log, but I’m not sure how to fix it. (I think it’s the reason for the disconnect)

    It refers to: ‘privacy-blocked’ and ‘privacy-blocked.ulaw’. Any ideas? I’m a noob.

    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:2] GotoIf(“SIP/102-0000000e“, “1?:no_local“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:3] Set(“SIP/102-0000000e“, “CALLER_COS_ID=1“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:4] Set(“SIP/102-0000000e“, “CALLER_COS_NAME=cos-all“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:5] Set(“SIP/102-0000000e“, “CALLED_COS_ID=“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:6] GotoIf(“SIP/102-0000000e“, “0?same_cos“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:7] Set(“SIP/102-0000000e“, “PRIVATE_COS=“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:8] GotoIf(“SIP/102-0000000e“, “0?no_private“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:9] Set(“SIP/102-0000000e“, “ALLOWED_COS_LIST=“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:10] Set(“SIP/102-0000000e“, “ALLOWED_COS=FALSE“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:11] GotoIf(“SIP/102-0000000e“, “0?allowed“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:12] NoOp(“SIP/102-0000000e“, “The CoS cos-all is not allowed, dropping call“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:13] Playback(“SIP/102-0000000e“, “privacy-blocked“) in new stack
    [2020-05-12 15:05:08] VERBOSE[20010][C-0000000f] file.c: <SIP/102-0000000e> Playing ‘privacy-blocked.ulaw’ (language ‘en’)
    [2020-05-12 15:05:09] VERBOSE[20010][C-0000000f] pbx.c: Executing [s@sub-check-cos-privacy:14] Hangup(“SIP/102-0000000e“, ““) in new stack
    [2020-05-12 15:05:09] VERBOSE[20010][C-0000000f] pbx.c: Spawn extension (sub-check-cos-privacy, s, 14) exited non-zero on ‘SIP/102-0000000e’

    0
Viewing 3 replies - 1 through 3 (of 3 total)
  • Replies
    Up
    0
    Down

    Try executing the following command on the Linux console:

    vitalpbx –fully-dump-conf

    0
    Syirrus
    Participant
    Up
    0
    Down

    @ing-joserivera26

     

    Thank you very much, that command worked!  I can now make audio calls inside in my NAT and outside of the NAT (my VitalPBX is hosted externally with DigitalOcean).

    For some reason video will not work though, and only seems to work when I’m within the same NAT without CoTurn.  I even have CoTurn setup which is relaying properly. I have video support enabled in VitalPBX as well. I’m using h.264 too and selected as a codec in VitalPBX. I’m using MicroSip and Baresip as clients. I’m new to this whole SIP environment and I’m starting to thing that all SIP clients are NOT created equally. Any advice for some things I might want to check?

    0
    kasto
    Participant
    Up
    0
    Down
    I have the same issue as Syirrus on a fresh 3.0.1 installation. Dialing out is working, dialing in is working, dialing feature codes is working but local extension can’t call each other. These are the last lines in the log:

    — Executing [20@sub-local-dialing:3] Set(“IAX2/36-13577”, “_DESTINATION_STATE=NOT_INUSE”) in new stack
    — Executing [20@sub-local-dialing:4] Set(“IAX2/36-13577”, “_DESTINATION_NUMBER=20”) in new stack
    — Executing [20@sub-local-dialing:5] Set(“IAX2/36-13577”, “_DESTINATION_COS_NAME=cos-all”) in new stack
    — Executing [20@sub-local-dialing:6] Gosub(“IAX2/36-13577”, “sub-check-cos-privacy,s,1(cos-all,1,cos-all)”) in new stack
    — Executing [s@sub-check-cos-privacy:1] NoOp(“IAX2/36-13577”, “Checking Privacy of CoS: cos-all”) in new stack
    — Executing [s@sub-check-cos-privacy:2] GotoIf(“IAX2/36-13577”, “1?:no_local”) in new stack
    — Executing [s@sub-check-cos-privacy:3] Set(“IAX2/36-13577”, “CALLER_COS_ID=1”) in new stack
    — Executing [s@sub-check-cos-privacy:4] Set(“IAX2/36-13577”, “CALLER_COS_NAME=cos-all”) in new stack
    — Executing [s@sub-check-cos-privacy:5] Set(“IAX2/36-13577”, “CALLED_COS_ID=”) in new stack
    — Executing [s@sub-check-cos-privacy:6] GotoIf(“IAX2/36-13577”, “0?same_cos”) in new stack
    — Executing [s@sub-check-cos-privacy:7] Set(“IAX2/36-13577”, “PRIVATE_COS=”) in new stack
    — Executing [s@sub-check-cos-privacy:8] GotoIf(“IAX2/36-13577”, “0?no_private”) in new stack
    — Executing [s@sub-check-cos-privacy:9] Set(“IAX2/36-13577”, “ALLOWED_COS_LIST=”) in new stack
    — Executing [s@sub-check-cos-privacy:10] Set(“IAX2/36-13577”, “ALLOWED_COS=FALSE”) in new stack
    — Executing [s@sub-check-cos-privacy:11] GotoIf(“IAX2/36-13577”, “0?allowed”) in new stack
    — Executing [s@sub-check-cos-privacy:12] NoOp(“IAX2/36-13577”, “The CoS cos-all is not allowed, dropping call”) in new stack
    — Executing [s@sub-check-cos-privacy:13] Playback(“IAX2/36-13577”, “privacy-blocked”) in new stack
    — <IAX2/36-13577> Playing ‘privacy-blocked.ulaw’ (language ‘de’)
    — Executing [s@sub-check-cos-privacy:14] Hangup(“IAX2/36-13577”, “”) in new stack
    == Spawn extension (sub-check-cos-privacy, s, 14) exited non-zero on ‘IAX2/36-13577’
    — Hungup ‘IAX2/36-13577’

    The previous 2 replies shown to me in the forum seem to belong to a different thread, so I suppose the forum is somewhat screwed up. Anyway, how can I enable local calls between extensions?

    • This reply was modified 2 weeks, 6 days ago by kasto.
    0
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.