Call still in queue after hang-up

VitalPBX Community Support General Discussion Call still in queue after hang-up

  • Post
    tasagore
    Participant

    Hi

    I’m migrating from Elastix 2.3 to VitalPBX and one thing that works ok in Elastix seems that doesn’t work in the same way in VitalPBX: I have a queue with three operators, when a call is received all ring at same time but if the dialer hangs up, the phone call remains in the queue (and ringing) for ten seconds (+/-). In our old Elastix when the dialer hangs the queue also stops (if there is nobody else waiting).

    Any hint?

    0
Viewing 15 replies - 1 through 15 (of 16 total)
  • Replies
    Up
    0
    Down

    are you using dahdi trunks?

    0
    tasagore
    Participant
    Up
    0
    Down
    Posted by: mrivera

    are you using dahdi trunks?

    Yes, all seems work fine except that the hangup is not detected in the right way, when I receive a phone call it’s routed to queue 700, three SIP extensios rings at same time but if I hangup the queue is still ringing until it reaches 30 seconds from the begining (the time I have for that queue). If I do asterisk -rvvvvvv I can see that the hangup is not detected:

      == Spawn extension (cos-all, 517, 1) exited non-zero on 'SIP/517-00000008'

        -- SIP/517-00000008 Internal Gosub(sub-local-dialing,set_dial,1) complete GOSUB_RETVAL=

        -- Called SIP/517

        -- Local/517@queue-call-to-agents-00000006;1 is ringing

        -- Local/517@queue-call-to-agents-00000006;1 connected line has changed. Saving it until answer for DAHDI/i1/XXXXXXXXX-2

        -- SIP/517-00000008 is ringing

        -- Local/517@queue-call-to-agents-00000006;1 is ringing

        -- SIP/527-00000007 is ringing

        -- Local/527@queue-call-to-agents-00000007;1 is ringing

        -- SIP/501-00000006 is ringing

        -- Local/501@queue-call-to-agents-00000008;1 is ringing

        -- Nobody picked up in 30000 ms

        -- Nobody picked up in 30000 ms

        -- Nobody picked up in 30000 ms

    as you can see it was running for 30000 ms but the phone call was ended in the first 5000 ms. When Aterisk try to requeue the call seems that the hangup is detected in that moment:

    Span 1: Channel 0/1 got hangup, cause 102

        -- Stopped music on hold on DAHDI/i1/XXXXXXXXX-2

    Also I have Switchboard and if I use the Queue Waintg Calls Widget all the phone calls remains there forever.

     

    This is my hardware:

    pci:0000:05:00.0     wcb4xxp+     1397:08b4 OpenVox B400P

    pci:0000:07:00.0     wctdm+       e159:0001 Wildcard TDM400P REV E/F

     

    This is my Dahdi-profiles:

    ;Default BRI TE Profile - Default BRI TE Profile

    [p5](!)

    context = dahdi-incoming

    signalling = bri_cpe

    rxgain = 0.000

    txgain = 0.000

    usecallerid = yes

    hidecallerid = no

    relaxdtmf = no

    faxdetect = no

    echocancel = 128

    echocancelwhenbridged = yes

    switchtype = euroisdn

    inbanddisconnect = yes

    facilityenable = disabled

    overlapdial = no

    resetinterval = never

    pridialplan = unknown

    prilocaldialplan = national

    usecallingpres = yes

     

    0
    Up
    0
    Down

    Try to set the following configurations in the advanced tab of your DAHDI Profile:

    • hanguponpolarityswitch=yes
    • callprogress=yes

    Also you may check if you already configured the right DAHDI tonezone .

    0
    tasagore
    Participant
    Up
    0
    Down
    Posted by: mrivera

    Try to set the following configurations in the advanced tab of your DAHDI Profile:

    • hanguponpolarityswitch=yes
    • callprogress=yes

    Also you may check if you already configured the right DAHDI tonezone .

    My Timezone is right “(es) Spain” and I’ve added that params but still the same behaviour:

    [p5](!)

    context = dahdi-incoming

    signalling = bri_cpe

    rxgain = 0.000

    txgain = 0.000

    usecallerid = yes

    hidecallerid = no

    relaxdtmf = no

    faxdetect = no

    echocancel = 128

    echocancelwhenbridged = yes

    switchtype = euroisdn

    inbanddisconnect = yes

    facilityenable = disabled

    overlapdial = no

    resetinterval = never

    pridialplan = unknown

    prilocaldialplan = national

    usecallingpres = yes

    hanguponpolarityswitch = yes

    callprogress = yes

     

    0
    tasagore
    Participant
    Up
    0
    Down

    Don’t know if this helps but this is what my old Elastix shows:



       -- Executing [s@macro-hangupcall:51] Hangup("Local/517@from-queue-0000003d;2", "") in new stack

      == Spawn extension (macro-hangupcall, s, 51) exited non-zero on 'Local/517@from-queue-0000003d;2' in macro 'hangupcall'

      == Spawn extension (from-internal, h, 1) exited non-zero on 'Local/517@from-queue-0000003d;2'

        -- <Local/527@from-queue-0000003e;2>AGI Script hangup.agi completed, returning 0

        -- Executing [s@macro-hangupcall:51] Hangup("Local/527@from-queue-0000003e;2", "") in new stack

      == Spawn extension (macro-hangupcall, s, 51) exited non-zero on 'Local/527@from-queue-0000003e;2' in macro 'hangupcall'

      == Spawn extension (from-internal, h, 1) exited non-zero on 'Local/527@from-queue-0000003e;2'

        -- SIP/501-0000000a is ringing

        -- Local/501@from-queue-0000003f;1 is ringing

        -- Span 2: Channel 0/2 got hangup request, cause 16

        -- Stopped music on hold on DAHDI/i2/XXXXXXXXX-5

      == Spawn extension (ext-queues, 1, 9) exited non-zero on 'DAHDI/i2/XXXXXXXXX-5'

        -- Executing [h@ext-queues:1] Macro("DAHDI/i2/XXXXXXXXX-5", "hangupcall,") in new stack

    as you can see, the hangup is detected immediately

    0
    Up
    0
    Down

    Compare the dahdi configurations of your old pbx with the new one

    0
    tasagore
    Participant
    Up
    0
    Down
    Posted by: mrivera

    Compare the dahdi configurations of your old pbx with the new one

    I’ve tried to do that but the files are quite different (Elastix 2.3…), anyway all I can compare seems configured in the same way.

    0
    tasagore
    Participant
    Up
    0
    Down

    This is my old dahdi-channels.conf (just one channel, all have the same params):

    ; Span 2: B4/0/1 "B4XXP (PCI) Card 0 Span 1"
    group=0,12
    context=from-pstn
    switchtype = euroisdn
    signalling = bri_cpe
    channel => 5-6
    context = default
    group = 63

    chan_dahdi.conf:

    [trunkgroups]
    [channels]
    context=from-pstn
    signalling=fxs_ks
    rxwink=300              ; Atlas seems to use long (250ms) winks
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=no
    faxdetect=incoming
    echotraining=800
    rxgain=0.0
    txgain=0.0
    callgroup=1
    pickupgroup=1
    ;Uncomment these lines if you have problems with the disconection of your analog lines
    busydetect=yes
    busycount=8
    immediate=no
    language=es
    #include dahdi-channels.conf

    Seems the same configuration posted above in VitalPBX.

    0
    tasagore
    Participant
    Up
    0
    Down

    I’ve posted that I’ve two cards, the first one is for BRI lines (ISDN) and the second one for FXO lines (analog). Doesn’t matter if I made a phone call to ISDN or FXO, the hangup is not detected. I’ve added 

    hanguponpolarityswitch = yes

    callprogress = yes

    to FXO profiles (and BRI-TE but I think that ISDN does not use that parameters) but nothing changes.

     

    0
    Up
    0
    Down

    Did you already try to add this parameters in the advanced tab of the Dahdi profile:

    busydetect=yes
    busycount=8
    immediate=no
    0
    Up
    0
    Down

    Did you already try to add this parameters in the advanced tab of the Dahdi profile:

    busydetect=yes
    busycount=8
    immediate=no
    0
    tasagore
    Participant
    Up
    0
    Down
    Posted by: mrivera

    Did you already try to add this parameters in the advanced tab of the Dahdi profile:

    busydetect=yes
    busycount=8
    immediate=no

    Yes, but nothing changes, probably I’m missing something but I’m getting crazy with this 🙁

    ;Default BRI TE Profile - Default BRI TE Profile

    [p5](!)
    context = dahdi-incoming
    signalling = bri_cpe
    rxgain = 0.000
    txgain = 0.000
    usecallerid = yes
    hidecallerid = no
    relaxdtmf = no
    faxdetect = no
    echocancel = 128
    echocancelwhenbridged = yes
    switchtype = euroisdn
    inbanddisconnect = yes
    facilityenable = disabled
    overlapdial = no
    resetinterval = never
    pridialplan = unknown
    prilocaldialplan = national
    usecallingpres = yes
    busydetect=yes
    busycount=8
    immediate=no

     

    0
    Up
    0
    Down

    Are you sure that you assigned that profile to your E1?

    0
    tasagore
    Participant
    Up
    0
    Down
    Posted by: mrivera

    Are you sure that you assigned that profile to your E1?

    Yes, take a look to the attachment (same in other channels)

    0
    Up
    0
    Down

    Try with the following settings, keeping the previous settings

    busypattern=500,500
    answeronpolarityswitch=yes
    hanguponpolarityswitch=yes
    callprogress=yes
    ringtimeout=8000
    0
Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.