Cannot connect to AMI user

VitalPBX Community Support General Discussion Cannot connect to AMI user

  • Post
    Tassos
    Participant

    I have created an AMI user and gave permissions for my subnet (192.168.186.0/255.255.255.0) in order to connect xtelsio, a CTI like client.

    I have added port 5038 to the allowed firewall ports but I cannot connect to it. I even stopped the firewall but did not connect either.

    When connected with ssh to the VitalPBX machine, I can successfully telnet to port 5038.

    Is there something I am missing?

    0
Viewing 14 replies - 1 through 14 (of 14 total)
  • Replies
    Up
    0
    Down

    Post the output of the following command:

    asterisk -rx"manager show users"
    0
    Tassos
    Participant
    Up
    0
    Down

    [root@vitalpbx ~]# asterisk -rx”manager show users”

    username
    ——–
    admin
    TassosHome
    astmanager
    ——————-
    3 manager users configured.
    [root@vitalpbx ~]#

    0
    Tassos
    Participant
    Up
    0
    Down

    I made it to work by changing the bind address at the [general] section of “manager__10-general.conf” from 127.0.0.1  to  0.0.0.0

    I suppose this is not the correct way to do it.

    Waiting for your answer.

    0
    Gary
    Participant
    Up
    0
    Down
    Posted by: Tassos

    I made it to work by changing the bind address at the [general] section of “manager__10-general.conf” from 127.0.0.1  to  0.0.0.0

    I suppose this is not the correct way to do it.

    Waiting for your answer.

    I have a potential new customer that requires CTI screen pops, I could use xtelsio or Activa TSP, did you find the correct way to allow connections.

    Thanks,

    0
    Gary
    Participant
    Up
    0
    Down

    Would it be better put in (manager__50-ombutel-user.conf) with a permit of local network  or in (manager__50-1-users.conf)

     

    0
    Tassos
    Participant
    Up
    0
    Down

    I have put it there. Below is the contents of the file manager__50-1-users.conf

    But it does not work unless I change the bind address at manager__10-general.conf from 127.0.0.1 to 0.0.0.0

    ; *********************************************************************************
    ; @Date : Thu Jul 5 6:06:17 GMT 2018
    ; @Document : manager__50-1-users.conf
    ; @Author : VitalPBX
    ; @Platform : VitalPBX
    ; *********************************************************************************

    [admin]
    writetimeout = 100
    secret = xxxxxxxxxxxxxxx
    deny = 0.0.0.0/0.0.0.0
    permit = 192.168.186.0/255.255.255.0
    read = system,call,originate,log,verbose,command,agent,config,dtmf,user,cdr,dialplan,reporting
    write = system,call,originate,log,command,verbose,agent,user,dtmf,config,reporting,dialplan,cdr
    [TassosHome]
    writetimeout = 100
    secret = xxxxxxxxxxxxxxxx
    deny = 0.0.0.0/0.0.0.0
    permit = 192.168.184.0/255.255.255.0
    read = system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
    write = system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate

     

    0
    Up
    0
    Down

    The main bind address for AMI has been changed to 0.0.0.0 in the version 2.0.5

    0
    Gary
    Participant
    Up
    0
    Down

    I setup a new server and created a manager for xtelsio, some times it will connect and work good, other times the tapi driver can not connect to server even though no changes were made, I get an error “IP connect OK, but login failed”. is there any issues known in Vitalpbx with this connection.

    manager__10-general.conf

    [general]
    enabled = yes
    port = 5038
    bindaddr = 0.0.0.0
    displayconnects = no
    webenabled = no

     

    manager__50-ombutel-user.conf

    [asttapi]
    secret= XXXXXXXXXX
    deny= 0.0.0.0/0.0.0.0
    permit= 192.168.0.0/255.255.255.0
    read = system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
    write = system,call,log,verbose,command,agent,user,config,dtmf,reporting,cdr,dialplan,originate
    writetimeout = 5000

     

    VitalPBX 2.0.5-5 
    Asterisk 13.21.0-1 
    DAHDI 2.11.1-6 

     

     

    0
    Gary
    Participant
    Up
    0
    Down

    Back at the office checking on a test server, seems to be a problem with telnet login, I have to issue the command twice Sometimes.

     

    Asterisk Call Manager/2.10.4
    Action: Login
    Username: AstTapi
    Secret: Xn75CFbVfjRgggg3971

    Response: Error
    Message: Missing action in request

    Action: Login
    Username: AstTapi
    Secret: Xn75CFbVfjRgggg3971

    Response: Success
    Message: Authentication accepted

    Event: FullyBooted
    Privilege: system,all
    Status: Fully Booted

     

    0
    Gary
    Participant
    Up
    0
    Down

    Solved ?

    I setup the customers server at our office before taking it to customers site, we use a different sub net, I changed all of the IP settings to match new site including the bind address but have had intermittent tapi problems, I setup  new ami user and restarted asterisk any tapi now seems good ? not sure why but it working.

    0
    Up
    0
    Down

    Did you already allow the port 5038 in the firewall? 

    0
    Gary
    Participant
    Up
    0
    Down

    Yes as TCP

    0
    momi
    Participant
    Up
    0
    Down

    I installed ADAT for CTI screen pops, I receive incoming calls
    but I can’t call (transfer call to internal).
    Softphones on PCs work fine.
    Some idea?
    Thanks

    0
    momi
    Participant
    Up
    0
    Down

    Solved

    1) Deleted port 5038 in firewall
    	2) reactivated port 5038 in firewall
    	now works

     

    0
Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.