config reload removes queue members

VitalPBX Community Support General Discussion config reload removes queue members

  • Post
    gerrykernan
    Participant
    hi

    having a strange issue , if i make a config change on PBX and do a reload . all members of a queue get removed from the queue.

    even thought persistentmenbers is set to yes and database show list members as persistent

    agents log in via queuemetrics  could this casue issues

     

    for example

    /Queue/PersistentMembers/Q511 : Local/6019@queue-call-to-agents/n;0;1;Local/6019@queue-call-to-agents/n;Local/6019@queue-call-to-agents/n;;0|Local/6032@queue-call-to-agents/n;0;0;Local/6032@queue-call-to-agents/n;Local/6032@queue-call-to-agents/n;;0|Local/6022@queue-call-to-agents/n;0;1;Local/6022@queue-call-to-agents/n;Local/6022@queue-call-to-agents/n;;0|Local/6036@queue-call-to-agents/n;0;0;Local/6036@queue-call-to-agents/n;Local/6036@queue-call-to-agents/n;;0|Local/6016@queue-call-to-agents/n;0;1;Local/6016@queue-call-to-agents/n;Local/6016@queue-call-to-agents/n;;0|Local/6023@queue-call-to-agents/n;0;1;Local/6023@queue-call-to-agents/n;Local/6023@queue-call-to-agents/n;;0|Local/6013@queue-call-to-agents/n;0;0;Local/6013@queue-call-to-agents/n;Local/6013@queue-call-to-agents/n;;0|Local/6003@queue-call-to-agents/n;0;0;Local/6003@queue-call-to-agents/n;Local/6003@queue-call-to-agents/n;;0|Local/6037@queue-call-to-agents/n;0;0;Local/6037@queue-call-to-agents/n;Local/6037@queue-call-to-agents/n;;0|Local/6017@queue-call-to-agents/n;0;0;Local/6017@queue-call-to-agents/n;Local/6017@queue-call-to-agents/n;;0|Local/6020@queue-call-to-agents/n;0;0;Local/6020@queue-call-to-agents/n;Local/6020@queue-call-to-agents/n;;0|Local/6018@queue-call-to-agents/n;0;0;Local/6018@queue-call-to-agents/n;Local/6018@queue-call-to-agents/n;;0|Local/6011@queue-call-to-agents/n;0;1;Local/6011@queue-call-to-agents/n;Local/6011@queue-call-to-agents/n;;0|Local/6001@queue-call-to-agents/n;0;1;Local/6001@queue-call-to-agents/n;Local/6001@queue-call-to-agents/n;;0

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • Replies
    gerrykernan
    Participant
    Up
    0
    Down
    looks like i have this sorted,

    on qeuuemetrics i was using “Local/6003@queue-call-to-agents/n” to log agents in

    with that string , when i clicked update on an extension in the Vital PBX GUI , agents would get removed from the queue.

    i removed the trailing “/n” and this sorted the problem.

     

    gerry

    0
    gerrykernan
    Participant
    Up
    0
    Down
    hi

    anyone know why adding “/n” at end of the agent string would cause GUI to to remove the agents when i update an.

    looks like i need the /n at end of the Local channel so that queue cannot see status of the exten correctly

    issue only seems to happen when i update and extension entry .

     

    gerry

    0
    gerrykernan
    Participant
    Up
    1
    Down
    had to add the agents extension as to the relevant queue as dynamic agents.

     

    0
    Up
    0
    Down
    Thanks for sharing the solution.
    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.