Enabling WebRTC disables PJSIP

VitalPBX Community Support General Discussion Enabling WebRTC disables PJSIP

  • Post
    acoolov
    Participant
    none
    Up
    0
    Down
    Hello!

    When I try to register a WebRTC browser phone to a VitalPBX extension, it requires me to change the extension profile from UDP to WebRTC and the browser phone starts working. But my desk IP phone stops working, because it works on UDP. Then when I try to revert the extension back to UDP profile and go into that profile, and just enable WebRTC in that profile and put transport to Auto so that both IP desk phone and browser soft phone work on the same extenion, the desk phone becomes unavailable.

    How do I have both IP phone and webrtc softphone work on the same extensions and both ring on incoming calls?

    0
Viewing 11 replies - 1 through 11 (of 11 total)
  • Replies
    PitzKey
    Participant
    US
    Up
    1
    Down
    PJSIP and WebRTC uses different transports, it is impossible to have the same settings work for both types of endpoints.

    You need to create another device under that extension, and use each device exclusively with the profile settings suitable for that endpoint.

    1
    acoolov
    Participant
    none
    Up
    0
    Down
    How do I create another device and map it to the same extension? In the extension settings you can only choose UDP or WebRTC profile.
    0
    acoolov
    Participant
    none
    Up
    0
    Down
    I found it. You can add another device in the Devices drop down menu within the extension. Thanks!
    0
    acoolov
    Participant
    none
    Up
    0
    Down
    I added another device into extenion 203. The new device now shows 203_1. Do I authenticate the new device with ext 203_1 or can I use ext 203 for both devices still? I don’t want another device to show 203_1. It would look kind of lame.
    0
    acoolov
    Participant
    none
    Up
    0
    Down
    Just double checked, and yes, you have to authenticate the IP phone to 203 and the webrtc phone to ext 203_1 in order for them both to receive calls. Is there any way to always just use 203 without any additions?
    0
    PitzKey
    Participant
    US
    Up
    1
    Down
    As explained earlier, it’s not possible.

    Your end user won’t know that WebRTC is 203_1, as users will just dial 203 and it’ll ring both devices.

    1
    acoolov
    Participant
    none
    Up
    0
    Down
    Yes, but for them to log into the extension using a webrtc phone, they have to enter 203_1, instead of just 203. I believe in another asterisk based PBX, you’re able to put transport to Auto on the extension, that way any client can negotiate using their transport protocol.
    0
    PitzKey
    Participant
    US
    Up
    1
    Down
    There are more settings that are different. Eitherway, the login to the WebRTC app should NEVER be the SIP credentials.
    1
    acoolov
    Participant
    none
    Up
    0
    Down
    Oh ok, what do you suggest doing in this case? How should a webrtc authentication be handled with VitalPBX? I appreciate your input.
    0
    PitzKey
    Participant
    US
    Up
    1
    Down
    There’s two things, the SIP auth and the App auth. Eg, with VitXi WebRTC, the user never enters the SIP credentials, they login with whatever username the admin chose.
    1
    Maynor Peralta
    Keymaster
    US
    Up
    1
    Down
    Hello!

    As Sir PitzKey. Mentions, the PJSIP profile, and the WebRTC have different settings so that they can work correctly.

    You can set the transport to “auto” perfectly, but there are other settings that are strictly different like the “Media Encryption“, which in WebRTC should be “DTLS“.

    Remember that what is registered is a device of a certain extension. That is why we recommend creating the devices depending on the environment where they will be used.

    In VitXi WebRTC, the device assigned to the user is automatically registered, the credentials are obtained dynamically.

    Best regards!

    1
Viewing 11 replies - 1 through 11 (of 11 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.