End Point Manager – Multitenant

VitalPBX Community Support General Discussion End Point Manager – Multitenant

Up
0
Down
  • Post
    deanwalker
    Participant
    GB

    Hi there,

    We are trialing out Vital before purchasing. Everything seems to be great so far apart from the EPM.

    When provisioning it uses just the extension number in the auth/user when auto provisioning.

    This means its not connecting to the server as the username would be 

    T001101 and not 101

    Am i missing something?

    0
Viewing 15 replies - 1 through 15 (of 20 total)
  • Replies

    The current EPM doesn’t support Multi-tenant environment, however, we are already working in the next version of the EPM who will support MT.

    The first beta of the EPM will be available at the end of November (That’s what we expect)

    0
    Gary
    Participant

    Will this new EPM have ability to add user name & password for the phone pull request. or even a feature were once a configuration is pulled for the first time it is then disabled automaticly untill we re enable it.

     

    0
    deanwalker
    Participant
    GB

    Hi any update to this?

    Thanks

    0

    On the next RC (VitalPBX 2.3.9) the current EPM will have the capability to work with Multi-tenant and also with PJSIP devices

    0
    Gary
    Participant

    there is a setting I use on all Yealink phones but is missing from your templetes can this be added.

    voice.side_tone

     

    0
    PitzKey
    Participant
    US

    Some exciting news: https://vitalpbx.org/en/vitalpbx-2-3-9-rc/

    Endpoint Manager:

    Now it is possible to provision PJSIP devices.

    Now it is possible to provision devices that belong to other tenants

    0
    PitzKey
    Participant
    US

    @ing-joserivera26

    We are not signed up for the beta program yet, however, we’d like to try the new endpoint manager today.

    Is there a way how we can install that?

    Thank you

    0

    @pitzkey

    You may download the ISO from here: http://repo.vitalpbx.org/vitalpbx/isos/vitalpbx-2.3.9-RC1.iso

    Or install on a VPS using the following script: https://github.com/VitalPBX/VPS/tree/rc

    0
    PitzKey
    Participant
    US

    @ing-joserivera26

    Sorry I meant to ask if we can update Endpoint Manager to get that version installed on a existing installation?

    I actually don’t mind updating the entire PBX to 2.3.9, it’s a quiet day today. 

    Is there a way how we can update today?

    Thanks again

    0

    @pitzkey

    You may download the RC repo from the following link: http://repo.vitalpbx.org/vitalpbx/rc/vitalpbxrc.repo

    You must place this repo on the following path: /etc/yum.repos.d/

    0
    PitzKey
    Participant
    US

    @ing-joserivera26

    Thank you, I added the vitalpbxrc.repo. Do I need to disable the vitalpbx.repo, or I can just run yum update.

    Thanks tons for your assistance.

     

     

    0

    @pitzkey

    No, you don’t need to disable the main repo, just perform the update.

    0
    PitzKey
    Participant
    US

    @ing-joserivera26

    Thank you, when I ran ‘yum update -y’ I get the below errors

    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    kernel-tools-3.10.0-1062.4.3.e FAILED
    http://mirror.umd.edu/centos/7.7.1908/updates/x86_64/Packages/kernel-tools-3.10.0-1062.4.3.el7.x86_64.rpm: [Errno 12] Timeout on http://mirror.umd.edu/centos/7.7.1908/updates/x86_64/Packages/kernel-tools-3.10.0-1062.4.3.el7.x86_64.rpm: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
    Trying other mirror.
    kernel-3.10.0-1062.4.3.el7.x86 FAILED
    http://mirror.umd.edu/centos/7.7.1908/updates/x86_64/Packages/kernel-3.10.0-1062.4.3.el7.x86_64.rpm: [Errno 12] Timeout on http://mirror.umd.edu/centos/7.7.1908/updates/x86_64/Packages/kernel-3.10.0-1062.4.3.el7.x86_64.rpm: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
    Trying other mirror

    And it keeps on going without installing anything

    So I ran: ‘yum check-update | grep vpbx’ and installed all packages from vpbxrc

    The PBX shows:

    VitalPBX Carrier 2.3.9-1
    Asterisk 16.6.2-1
    DAHDI 2.11.1-7

    But I cannot map PJSIP extensions in Endpoint Manager.

    Am I missing anything?

     

    Thanks

    0

    We are checking

    0

    @pitzkey

    Looks like we forgot to include the EPM changes, so, we have release a new RC version: 2.3.9-2, you can proceed to update with the following these steps:

    • yum clean all
    • rm -rf /var/cache/yum/
    • yum update
    0
Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.