EPM won't configure TLS protocol properly on Yealink phones

VitalPBX Community Support General Discussion EPM won't configure TLS protocol properly on Yealink phones

  • Post
    acoolov
    Participant

    Hello friends, hope everyone is staying safe during this time.

     

    Trying to configure TLS with PJSIP extensions in VitalPBX and Yealink phones.

    I created the ssl certificate, tried both self signed and lets encrypt.

    Specified the TLS port 5061 and the cert to use in the PJSIP settings.

    Created a new PJSIP Profile and set it to TLS.

    Set the extension to use that profile.

    Created a host in EPM with PJSIP port 5061.

    Create a template with that host.

    Provisioned the phone, the phone provisions properly through http, and even gets the port 5061 from the config file, however, the phone still remains on UDP. I have to manually log into the Yealink phone web gui and change UDP to TLS, then the phone would register properly. 

     

    Does that mean the EPM won’t send out the TLS protocol config properly or what?

    0
Viewing 3 replies - 1 through 3 (of 3 total)
  • Replies
    Up
    0
    Down

    What Yealink phone do you have? What model?

    0
    acoolov
    Participant
    Up
    -1
    Down

    @ing-joserivera26

     

    I tried with t29g and t41p. Most Yealink phones have exactly the same firmware so it shouldn’t really matter what model they are a lot of times.

     

    0
    Up
    0
    Down

    May you export the provisioning file from your phone, just to compare with the settings available in the EPM

    0
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.