Error viewing extension after upgrade to VitalPBX v3

VitalPBX Community Support General Discussion Error viewing extension after upgrade to VitalPBX v3

  • Post
    ICTALL
    Participant
    We have a VitalPBX on Google Cloud.
    We recently upgraded our VitalPBX from the latest v2 to v3.0.8-1.
    Today I wanted to edit an exsting extension and got the error below.

    <b>Fatal error</b>: Uncaught TypeError: Argument 1 passed to vitalpbx\query::select() must be an instance of vitalpbx\schema, null given, called in /usr/share/vitalpbx/www/modules/extensions/ContactInfo.php on line 0 and defined in /usr/share/vitalpbx/www/includes/query.php:0 Stack trace: #0 /usr/share/vitalpbx/www/modules/extensions/ContactInfo.php(0): vitalpbx\query::select(NULL) #1 /usr/share/vitalpbx/www/modules/extensions/Models/Extension.php(0): modules\extensions\ContactInfo::getByExtension(41) #2 /usr/share/vitalpbx/www/modules/extensions/extensions.php(0): modules\extensions\Models\Extension->getContactInfo() #3 /usr/share/vitalpbx/www/modules/extensions/extensions.php(0): modules\extensions\extensions->read('41', NULL, Array) #4 /usr/share/vitalpbx/www/includes/app/Core.php(0): modules\extensions\extensions->getContent() #5 /usr/share/vitalpbx/www/includes/app/Core.php(0): app\Core->loadModuleAction('\\modules\\extens...', 'getContent') #6 /usr/share/vitalpbx/www/includes/app/Core.php(0): app\Core->_loadModule() #7 /us in <b>/usr/share/vitalpbx/www/includes/query.php</b> on line <b>0</b>

    The PBX is working normally and we have not detected other errors.
    Does anyone know whats happenend and how to solve this problem ?

     

     

     

     

    • This topic was modified 2 weeks, 2 days ago by ICTALL.
    • This topic was modified 2 weeks, 2 days ago by ICTALL.
    0
Viewing 2 replies - 1 through 2 (of 2 total)
  • Replies
    Up
    0
    Down
    Try installing the phonebook add-on in case you hadn’t installed yet. If you already have it installed, then, try updating to the latest version.
    0
    ICTALL
    Participant
    Up
    0
    Down
    We have installed the Add-on Phone Books v3.0.2-1 but we are still getting the same error when we select an extension for editing.
    0
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.