Error when updating from V2.1.1-1 to V2.3.1-2

VitalPBX Community Support General Discussion Error when updating from V2.1.1-1 to V2.3.1-2

Up
0
Down
  • Post
    DannyLarsen
    Participant
    none

    I have removed all addons

    When updating from the web gui update fails

    From command line after “rm -rf /var/cache/yum”   and   “yum clean all”  

    yum update vitalpbx

    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.oit.uci.edu
    * epel: mirrors.develooper.com
    * extras: mirror.fileplanet.com
    * updates: mirror.hostduplex.com
    Resolving Dependencies
    There are unfinished transactions remaining. You might consider running yum-complete-transaction, or “yum-complete-transaction –cleanup-only” and “yum history redo last”, first to finish them. If those don’t work you’ll have to try removing/installing packages by hand (maybe package-cleanup can help).
    –> Running transaction check
    —> Package vitalpbx.x86_64 0:2.1.1-1 will be updated
    —> Package vitalpbx.x86_64 0:2.3.1-2 will be an update
    –> Processing Dependency: vitalpbx-theme = 2.3.1-2 for package: vitalpbx-2.3.1-2.x86_64
    –> Processing Dependency: vitalpbx-sounds-es = 2.3.1-2 for package: vitalpbx-2.3.1-2.x86_64
    –> Processing Dependency: vitalpbx-sounds = 2.3.1-2 for package: vitalpbx-2.3.1-2.x86_64
    –> Processing Dependency: vitalpbx-monitor = 2.3.1-2 for package: vitalpbx-2.3.1-2.x86_64
    –> Processing Dependency: vitalpbx-asterisk-configs = 2.3.1-2 for package: vitalpbx-2.3.1-2.x86_64
    –> Processing Dependency: vitalpbx-g729 >= 2.0.0 for package: vitalpbx-2.3.1-2.x86_64
    –> Processing Dependency: vitalpbx-dynamic-routing >= 2.0.0 for package: vitalpbx-2.3.1-2.x86_64
    –> Processing Dependency: asterisk >= 16.2.1 for package: vitalpbx-2.3.1-2.x86_64
    –> Running transaction check
    —> Package asterisk.x86_64 0:13.21.0-1 will be updated
    —> Package asterisk.x86_64 0:13.23.1-1 will be updated
    —> Package asterisk.x86_64 0:16.2.1-1 will be an update
    –> Processing Dependency: asterisk-voicemail = 16.2.1-1 for package: asterisk-16.2.1-1.x86_64
    –> Processing Dependency: asterisk-dpma = 16.2.1-1 for package: asterisk-16.2.1-1.x86_64
    –> Processing Dependency: asterisk-doc = 16.2.1 for package: asterisk-16.2.1-1.x86_64
    –> Processing Dependency: asterisk-dahdi = 16.2.1-1 for package: asterisk-16.2.1-1.x86_64
    –> Processing Dependency: asterisk-core = 16.2.1-1 for package: asterisk-16.2.1-1.x86_64
    —> Package vitalpbx-asterisk-configs.x86_64 0:2.1.1-1 will be updated
    —> Package vitalpbx-asterisk-configs.x86_64 0:2.3.1-2 will be an update
    —> Package vitalpbx-dynamic-routing.x86_64 0:1.0.0-1 will be updated
    —> Package vitalpbx-dynamic-routing.x86_64 0:2.2.0-1 will be an update
    —> Package vitalpbx-g729.x86_64 0:2.0.0-1 will be installed
    –> Processing Dependency: asterisk-g729 >= 2.0.0-2 for package: vitalpbx-g729-2.0.0-1.x86_64
    —> Package vitalpbx-monitor.x86_64 0:2.1.1-1 will be updated
    —> Package vitalpbx-monitor.x86_64 0:2.3.1-2 will be an update
    —> Package vitalpbx-sounds.x86_64 0:2.1.1-1 will be updated
    —> Package vitalpbx-sounds.x86_64 0:2.3.1-2 will be an update
    —> Package vitalpbx-sounds-es.x86_64 0:2.1.1-1 will be updated
    —> Package vitalpbx-sounds-es.x86_64 0:2.3.1-2 will be an update
    —> Package vitalpbx-themes.x86_64 0:2.1.1-1 will be updated
    —> Package vitalpbx-themes.x86_64 0:2.3.1-2 will be an update
    –> Running transaction check
    —> Package asterisk-core.x86_64 0:13.21.0-1 will be updated
    –> Processing Dependency: asterisk-core = 13.21.0-1 for package: asterisk-pjsip-13.21.0-1.x86_64
    –> Processing Dependency: asterisk-core = 13.21.0-1 for package: asterisk-odbc-13.21.0-1.x86_64
    —> Package asterisk-core.x86_64 0:13.23.1-1 will be updated
    –> Processing Dependency: asterisk-core = 13.23.1-1 for package: asterisk-pjsip-13.23.1-1.x86_64
    –> Processing Dependency: asterisk-core = 13.23.1-1 for package: asterisk-odbc-13.23.1-1.x86_64
    —> Package asterisk-core.x86_64 0:16.2.1-1 will be an update
    –> Processing Dependency: libunbound.so.2()(64bit) for package: asterisk-core-16.2.1-1.x86_64
    –> Processing Dependency: libcodec2.so.0.8()(64bit) for package: asterisk-core-16.2.1-1.x86_64
    —> Package asterisk-dahdi.x86_64 0:13.21.0-1 will be updated
    —> Package asterisk-dahdi.x86_64 0:13.23.1-1 will be updated
    —> Package asterisk-dahdi.x86_64 0:16.2.1-1 will be an update
    —> Package asterisk-doc.x86_64 0:13.21.0-1 will be updated
    —> Package asterisk-doc.x86_64 0:13.23.1-1 will be updated
    —> Package asterisk-doc.x86_64 0:16.2.1-1 will be an update
    —> Package asterisk-dpma.x86_64 0:16.2.1-1 will be installed
    —> Package asterisk-g729.x86_64 0:2.0.0-2 will be installed
    –> Processing Dependency: libbcg729.so.0()(64bit) for package: asterisk-g729-2.0.0-2.x86_64
    —> Package asterisk-voicemail.x86_64 0:13.21.0-1 will be updated
    —> Package asterisk-voicemail.x86_64 0:13.23.1-1 will be updated
    —> Package asterisk-voicemail.x86_64 0:16.2.1-1 will be an update
    –> Running transaction check
    —> Package asterisk-core.x86_64 0:13.21.0-1 will be updated
    —> Package asterisk-odbc.x86_64 0:13.21.0-1 will be updated
    —> Package asterisk-odbc.x86_64 0:13.23.1-1 will be updated
    —> Package asterisk-odbc.x86_64 0:16.2.1-1 will be an update
    —> Package asterisk-pjsip.x86_64 0:13.21.0-1 will be updated
    —> Package asterisk-pjsip.x86_64 0:13.23.1-1 will be updated
    —> Package asterisk-pjsip.x86_64 0:16.2.1-1 will be an update
    —> Package bcg729.x86_64 0:2.0.0-1 will be installed
    —> Package codec2.x86_64 0:0.8.1-1.el7 will be installed
    —> Package unbound-libs.x86_64 0:1.6.6-1.el7 will be installed
    –> Processing Dependency: libevent-2.0.so.5()(64bit) for package: unbound-libs-1.6.6-1.el7.x86_64
    –> Running transaction check
    —> Package libevent.x86_64 0:2.0.21-4.el7 will be installed
    –> Finished Dependency Resolution
    Error: Package: asterisk-odbc-13.21.0-1.x86_64 (@vpbx)
    Requires: asterisk-core = 13.21.0-1
    Removing: asterisk-core-13.21.0-1.x86_64 (@vpbx)
    asterisk-core = 13.21.0-1
    Updated By: asterisk-core-16.2.1-1.x86_64 (vpbx)
    asterisk-core = 16.2.1-1
    Removing: asterisk-core-13.23.1-1.x86_64 (installed)
    asterisk-core = 13.23.1-1
    Updated By: asterisk-core-16.2.1-1.x86_64 (vpbx)
    asterisk-core = 16.2.1-1
    Available: asterisk-core-13.17.2-1.x86_64 (vpbx)
    asterisk-core = 13.17.2-1
    Available: asterisk-core-13.19.0-1.x86_64 (vpbx)
    asterisk-core = 13.19.0-1
    Available: asterisk-core-16.2.0-1.x86_64 (vpbx)
    asterisk-core = 16.2.0-1
    Error: Package: asterisk-pjsip-13.21.0-1.x86_64 (@vpbx)
    Requires: asterisk-core = 13.21.0-1
    Removing: asterisk-core-13.21.0-1.x86_64 (@vpbx)
    asterisk-core = 13.21.0-1
    Updated By: asterisk-core-16.2.1-1.x86_64 (vpbx)
    asterisk-core = 16.2.1-1
    Removing: asterisk-core-13.23.1-1.x86_64 (installed)
    asterisk-core = 13.23.1-1
    Updated By: asterisk-core-16.2.1-1.x86_64 (vpbx)
    asterisk-core = 16.2.1-1
    Available: asterisk-core-13.17.2-1.x86_64 (vpbx)
    asterisk-core = 13.17.2-1
    Available: asterisk-core-13.19.0-1.x86_64 (vpbx)
    asterisk-core = 13.19.0-1
    Available: asterisk-core-16.2.0-1.x86_64 (vpbx)
    asterisk-core = 16.2.0-1
    You could try using –skip-broken to work around the problem
    ** Found 7 pre-existing rpmdb problem(s), ‘yum check’ output follows:
    asterisk-13.23.1-1.x86_64 is a duplicate with asterisk-13.21.0-1.x86_64
    asterisk-core-13.23.1-1.x86_64 is a duplicate with asterisk-core-13.21.0-1.x86_64
    asterisk-dahdi-13.23.1-1.x86_64 is a duplicate with asterisk-dahdi-13.21.0-1.x86_64
    asterisk-doc-13.23.1-1.x86_64 is a duplicate with asterisk-doc-13.21.0-1.x86_64
    asterisk-odbc-13.23.1-1.x86_64 is a duplicate with asterisk-odbc-13.21.0-1.x86_64
    asterisk-pjsip-13.23.1-1.x86_64 is a duplicate with asterisk-pjsip-13.21.0-1.x86_64
    asterisk-voicemail-13.23.1-1.x86_64 is a duplicate with asterisk-voicemail-13.21.0-1.x86_64

    0
Viewing 2 replies - 1 through 2 (of 2 total)
  • Replies

    You must execute the following command:

    yum-complete-transaction

    then:

    yum update -y
    0
    DannyLarsen
    Participant
    none

    couple things that might help someone else on this issue

    yum-utils was not installed so I could not run yum-complete-transaction

    I had to run:

    yum install yum-utils

    at this point I still could not run yum-complete-transaction

    I had to add the path

    /usr/sbin/yum-complete-transaction

    then this worked

    Thanks

    0
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.