Extension import problem

  • Post
    yazarlwin
    Participant
    Up
    2
    Down
    We faced issue when we imported the extensions. Please see attached picture.
    Attachments:
    You must be logged in to view attached files.
    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • Replies
    Up
    0
    Down
    Can you share the CSV you are using?

    As a workaround, you can try downloading the CSV template and upload again.

    0
    yazarlwin
    Participant
    Up
    0
    Down
    We used downloaded template from WebUI but no success.
    0
    Raj-205
    Participant
    Up
    0
    Down
    After a recent upgrade, I am getting the same ERROR for Importing extensions.
    0
    Joseph Giragoss
    Participant
    Up
    0
    Down
    The new version 3.0.6-1 version has many more fields which is great. However there are a couple problems with the template that doesn’t allow upload. When I export existing extensions I see:

    • There are two extra columns of data at the end without any headers
    • The FollowMe column extracts the list of extensions but does not separate them with space of a comma.
    • The error I get says:<b>Exception</b>: Undefined property: stdClass::$vm_password at file /usr/share/vitalpbx/www/modules/import_extensions/import_extensionsDB.php on line 0

    I hope this help to fix the error.

    0
    Up
    0
    Down
    Please update to version 3.0.6-2, In this version, we fixed some issues introduced on version 3.0.6-1
    0
    Joseph Giragoss
    Participant
    Up
    0
    Down
    The problem is solved partially; it works with minor modifications.

     

    When I expert extensions, there are 2 columns without a header. By looking at the import template, the first one is for “Send welcome email”.

     

    I usually create new extensions for the same customer by exporting extensions and then changing the extension number. With this new fix, which has fixed the problem partially,  now I add the header “Send welcome email” to the last but one column and delete the last columns. It would be nice to know what the last columns with missing header is for.

    Thank you again for your excellent work and prompt response.

    0
    Up
    0
    Down
    Giragoss,

    Go to the Import extensions, download the CSV template, and there you will see the description of each header.

    0
    Joseph Giragoss
    Participant
    Up
    0
    Down
    Thank you for your prompt response. I have attached a file.

    Rows 2 and 3 are from Import extensions template.

    Rows 6,7 and 8 are from Export extensions. Row 8 contains data.

    When exporting extensions, columns AX and AY have empty headers.

    The Import extensions template, has a header for AX column but empty for AY column.

     

    Thank you again!

    Attachments:
    You must be logged in to view attached files.
    0
    Afuerst
    Participant
    US
    Up
    0
    Down
    Me and my team are experiencing the same thing with the import erroring out. Going to try again after an upgrade to 3.0.6-2.

    Is there anything special to get the csv import functioning after the upgrade? It seems like it just needs a double check that the column headings are correct. I’ve noticed the difference in number of columns between the import and export csvs as well.

    0
    Afuerst
    Participant
    US
    Up
    0
    Down
    I can confirm that the csv no longer errors out after the update to 3.0.6-2, but not all values on the csv are getting updated in the system accordingly. The codecs data didn’t upload or update, as well as the max number of contacts. In addition, the welcome letter was sent and users were successfully placed in queues.

     

    Like what’s mentioned above in others’ posts, I also noticed the columns mismatching. I think that’s the culprit to the problem I had because if you download the import template and export extensions, the codecs column is the first one that is out of sync between the export and import file.

     

    Any help or information is greatly appreciated!

    0
    jo-cpa
    Participant
    Up
    0
    Down
    This is extremely frustrating for us as well.  The Export and Import templates do not match.  It is almost a useless (or time consuming at the very least) feature that should be addressed.
    0
    jo-cpa
    Participant
    Up
    0
    Down
    Well, the good news is that we’ve got a working import template to create Extensions and Devices.  Just got that going and it seems to work ok… despite the export copy to the import template is a pain.

    Does VitXi WebRTC’s interface have any config files/db to touch to complete that portion of the set up for user’s in a more efficient manner?

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • The forum ‘New Provisioning System (EPM) – 2021 (Beta)’ is closed to new topics and replies.