Fax Device failed registration

VitalPBX Community Support General Discussion Fax Device failed registration

Up
0
Down
  • Post
    DannyLarsen
    Participant
    none

    VitalPBX V 2.3.1-2

    I am testing the fax device I have setup a test fax device ttyIAX1, I have set up the global fax settings and the IAX2 settings

    The /var/log/iaxmodem/ttyIAX1 log file shows

    Registration Failed.

    Terminiating on signal 15…..

    Can you help

    Thanks

    0
Viewing 15 replies - 1 through 15 (of 22 total)
  • Replies
    toxicfusion
    Participant

    Faxing is not working for me either on 2.3.1-2 (Extension Virtual fax). Just thought I’d add to this.

    When calling fax DID, it answers as fax. However, faxing to the DID – fax machine states fax negotiation failed & fax failed

     

     

    0

    After create any fax device, you must to apply changes. You may check through the status report if the IAX Device is registered 

    0
    DannyLarsen
    Participant
    none

    I had it working in  the beta version but now in the release version it fails registration

    Shows this below in the CLI or the Status

    peer  ttyIAX1 1 UNKNOWN FAX ttyIAX1

    I also removed and re installed the virtual fax addon with the same result

    0
    DannyLarsen
    Participant
    none

    Update

    I removed the fax device again ( 4th time ) and re added it again

    Now it added ttyIAX3 and it is registered and working

    0
    mo10
    Participant

    Same problem here with a fresh Vital-PBX Install 2.3.1-2.
    Did not try to delete the fax-device 4 times yet.

    @vitalpbx: Any fix?

    Thanks!

    0
    mo10
    Participant

    only removing fax device and adding it again helped.

    But then….sending did not work.

    Hint: PLEASE DON’T USE “@” in secret:

    cat /etc/iaxmodem/ttyIAX1
    secret FfierDfaxU2vRDu5W@Rm

    Will result in: No answer from remote

    Please VitalPBX-Team, change that. THANKS!

    0
    kbohannon
    Participant
    Posted by: @mo10

    only removing fax device and adding it again helped.

     

    I am on my ninth fax device; always “Failed registration” in the log. This is 2.3.4-2. Has this been fixed in the beta? I am about to try an upgrade to 2.3.5-1 just to see.

    0
    mo10
    Participant

    @kbohannon

    i don’t think this is fixed since nobody answered here.

    Please send output of:
    cat /etc/iaxmodem/ttyIAX1

    Or the ttyIAX that is used by VitalPBX in your case.

    It there a @ in the Secret?

    0
    kbohannon
    Participant

    [root@mtz iaxmodem]# cat ttyIAX10
    device /dev/ttyIAX10
    owner uucp:uucp
    mode 660
    port 3570
    refresh 60
    server 127.0.0.1
    peername ttyIAX10
    secret 94!wX$mTv7tZAUuy4R
    cidname Client Firm
    cidnumber 17135551212
    codec ulaw

    [root@mtz iaxmodem]# cat ttyIAX10
    [2019-08-04 13:28:37.683565] Registration failed.
    [2019-08-04 13:28:40.252922] Terminating on signal 15…

    0
    mo10
    Participant

    @kbohannon

    Please check firewall Settings inside VitalPBX. Or disable it for testing.
    This should not matter since it’s localhost (127.0.0.1).
    But give it a try.

    0
    kbohannon
    Participant

    @mo10

    Unfortunately, no. Neither did the beta upgrade work. I am going to just rebuild it from scratch.

    0
    kbohannon
    Participant

    On a fresh install of 2.3.4-2 onto CentOS 7, same problem. I give up. I have one law firm who really liked this feature but I can’t keep it working. FaxPlus worked for them before so I am just going to go with that.

    0
    mo10
    Participant

    Since i am using KVM virtualization i just set up my own VM with hylafax and some optimazations.

    0
    kbohannon
    Participant

    @mo10

    And you still have the VitalPBX GUI interface with it? How did you manage this?

    0
    mo10
    Participant

    @kbohannon

    i like this (and the clients as well) even more (Fax-Printer):
    https://sourceforge.net/projects/wphf-reloaded/

    0
Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.