firewall save button produces a blank error and kills ha replication

VitalPBX Community Support Reporting an Issue firewall save button produces a blank error and kills ha replication

  • Post
    nsides
    Participant
    i have an ha pair, 4cpu 8gb ram for each.  last week, i had to blow away both installs, reinstall, and restore a backup.  mayhem.  had to destroy and rebuild the cluster.  we’ve ironed out most of the hiccups, but i’m stuck on the firewall settings.  any time i click ‘save’, i get a blank error message.  there are no details when i ‘inspect element’.

    if i was editing the whitelist — adding an entry, replication stops.  when i run ‘systemctl status mariadb -l’, i see:

    Nov 12 07:05:26 tc001spr1.sequrevoice.local mysqld[896]: 2020-11-12 7:05:26 564 [ERROR] Slave SQL: Error ‘Duplicate entry ’15’ for key ‘PRIMARY” on query. Default database: ‘ombutel’. Query: ‘insert into ombutel.ombu_firewall_whitelist (host,description,default) values (‘173.218.92.36′,’Joyce Tech’,’no’)’, Gtid 0-1-11521, Internal MariaDB error code: 1062

    and

    Nov 12 07:05:24 tc001spr2.sequrevoice.local mysqld[5082]: 2020-11-12 7:05:24 123485 [ERROR] Slave SQL: Error ‘Duplicate entry ’15’ for key ‘PRIMARY” on query. Default database: ‘ombutel’. Query: ‘insert into ombutel.ombu_firewall_whitelist (host,description,default) values (‘173.218.92.36′,’Joyce Tech’,’no’)’, Gtid 0-2-11522, Internal MariaDB error code: 1062

    looking at the mysql table, those values have indeed been added to both servers.  if i try and ‘start slave;’ or restart mariadb, i get the same error and notification that replication has stopped.  i can manually delete those entries and start slave in each, but at that point my whitelisted ips are gone.  once they’ve been removed and the slave restarted, it replicates normally. i can insert the data into the table using the query provided in the error, and it replicates to the other server correctly.

    i get a similar error when i reboot a server, but that’s in the asterisk.queues_log table.  once i remove the duplicate from that server and restart the slave, all is well again.

     

    0
  • You must be logged in to reply to this topic.