Follow Me with Prompt Callee Enabled

VitalPBX Community Support General Discussion Follow Me with Prompt Callee Enabled

Up
0
Down
  • Post
    PitzKey
    Participant
    US

    Hi guys,

    FollowMe setup:

    -Initial ring time = 5 Seconds
    -Ring strategy=Ring All
    -FollowMe list = Extension and External Number.
    -Prompt Callee = Enabled.
    -All other Greetings, such as “Please hold while I try to locate” etc, are disabled.

    2 issues:

    1) As soon as the external number answers the call, it stops ringing on the desk phone. Even the external number (callee) did not yet press 1 or 2.

    2) If the external number does not press 1 or 2 and chooses to hang up instead, the call gets disconnected.

    See log for issue 2: https://pastebin.com/rP7iHSKe (raw version)

    Let me know if you need any further info.

     

    Thanks

     

    0
Viewing 15 replies - 1 through 15 (of 15 total)
  • Replies
    PitzKey
    Participant
    US

    Bump.

    No one has this issue?

    0
    PitzKey
    Participant
    US

    Bump?

    0

    This is how it works, because, when you receive the announcement to confirm or not the call, actually you already answer the call, but, you can decide if accept it or not.

    We will check the possibility to continue ringing the internal phones if the external callee didn’t accept the call, but, I cannot assure anything

    0
    PitzKey
    Participant
    US

    Sorry about the delayed response.

    I’d look at it this way

    Caller = Channel-A
    DeskPhone = Channel-B
    FollowMe Cellphone = Channel-C

    And lets set there’s a 5 second initial ring time.

    As soon as the caller calls in, Channel-B and Channel-C are immediately established, however, Channel-C has a 5 Second wait() before it dials the cellphone.

    If the DeksPhone answers, Channel-A and Channel-B are getting bridged and the PBX destroys Channel-C.

    If the Cellphone answers, Channel-B continues ringing, and only once Channel-C received a DTMF of the number 1 the PBX will bridge Channel-A and Channel-C and finally destroy Channel-B.

    That way, it will also fix the current annoying new call on the desk phone after the initial ring time.

    We have a couple of emergency systems that are routed with cellphones and landlines, we can’t migrate them over just for this reason.

    I might be able to help working on it and you can tell me a bit how the current FollowMe logic works, and where I should look for the dialplan.

    Thank you

    0
    mo10
    Participant
    I get your point and this is something special that was not intended for the follow me feature. But still nice if it could be done.

    Regarding your “That way, it will also fix the current annoying new call on the desk phone after the initial ring time.”
    Just set: “Initial Ring Time” to “Not Ring”. This will fix that and will ring both extensions right away.

    0
    mo10
    Participant
    @PitzKey
    i found a solution. Contact me. If we have a final result we can repost here.
    0
    PitzKey
    Participant
    US
    @mo10 Sorry I didn’t see your post on the old forum. I will contact you.
    0
    PitzKey
    Participant
    US
    Hi @ing-joserivera26

    I tested the possibility of having this in place, the below seems to be working fine. I used extension 201 as the “cellphone”.

    With this dialplan, I am focusing on the idea of having a 5 seconds initial ring time, and after 5 seconds the PBX starts calling the FollowMe number as well, so the primary extension continues to ring without any interruption.

    The “FollowMe” number in this case is 201. Once 201 answers, they are prompted to press 1, and the call will continue ringing at 100 as long as 201 did not press 1. Again, if 201 pressed 2 or didn’t enter anything, the call will continue ringing by 100.

    Dialplan:

    [cos-all]
    exten => 100,1,Noop(Testing follow me)
    exten => 100,n,Dial(Local/deskphone-100@my-phones&Local/cellphone-100@my-phones,30)
    exten => 100,n,Hangup

    [my-phones]
    exten => deskphone-100,1,Noop(Dialing extension 100)
    exten => deskphone-100,n,Dial(SIP/100)

    exten => cellphone-100,1,Noop(Calling cellphone of extension 100 and 5 seconds before dialing)
    exten => cellphone-100,n,Wait(5)
    exten => cellphone-100,n,Dial(SIP/201,,HhTtU(followme-confirmation))

    [followme-confirmation]
    exten => s,1,Noop(Entered follow me confirmation sub)
    exten => s,n(start),Set(attempts=$[0${attempts}+1])
    exten => s,n,Read(accept,you_have_an_incoming_call,1,,1,5)
    exten => s,n,GotoIf($[$["${accept}" != ""] | $["${attempts}" = "3"]]?end:start)
    exten => s,n(end),ExecIf($["${accept}" = "1"]?Noop(Connecting Call...):Set(_GOSUB_RESULT=ABORT))
    exten => s,n,Return

    This obviously needs more work, for example, if 201 answers the call but didn’t press 1 yet, and in the meantime 100 answered, you want that as soon as 201 presses 1 they should hear something like “Call has already been answered”, you also want to check if 100 already answered before playing the “press 1” on every loop, and if so play the “already answered” greeting and Return().

    Let me know if you need any further troubleshooting.

    Thanks

    0
    You need to try with external numbers, that’s the real scenario.
    0
    PitzKey
    Participant
    US
    Will do. Thanks
    0
    mo10
    Participant
    The included feature in Asterisk FollowMe() will do exactly what @PitzKey wants.
    (But it will also ask to press a number on internal calls.)

    It’s a cool feature for external calls.

    0
    We are not using the follow-me application because it has issues on external calls. However, we will do more tests on Asterisk 17.
    0
    mo10
    Participant
    We are not using the follow-me application because it has issues on external calls. However, we will do more tests on Asterisk 17.

    Was working totally fine on my tests with latest VitalPBX. Did exactly what it should do everytime.

    1
    PitzKey
    Participant
    US
    Hi @ing-joserivera26

    I just tested the below with an external phone number, it worked just fine!!

    [cos-all-custom]
    exten => 100,1,Noop(Testing follow me)
    exten => 100,n,Dial(Local/deskphone-100@my-phones&Local/cellphone-100@my-phones,30)
    exten => 100,n,Hangup

    [my-phones]
    exten => deskphone-100,1,Noop(Dialing extension 100)
    exten => deskphone-100,n,Dial(SIP/100)

    exten => cellphone-100,1,Noop(Calling cellphone of extension 100 and 5 seconds before dialing)
    exten => cellphone-100,n,Wait(5)
    exten => cellphone-100,n,Dial(local/812XXXXXXX@cos-all,,HhTtU(followme-confirmation))

    [followme-confirmation]
    exten => s,1,Noop(Entered follow me confirmation sub)
    exten => s,n(start),Set(attempts=$[0${attempts}+1])
    exten => s,n,Read(accept,followme/no-recording&followme/options,1,,1,5)
    exten => s,n,GotoIf($[$["${accept}" != ""] | $["${attempts}" = "3"]]?end:start)
    exten => s,n(end),ExecIf($["${accept}" = "1"]?Noop(Connecting Call...):Set(_GOSUB_RESULT=ABORT))
    exten => s,n,Return

    Let me know if you need me to test anything further

    Thank you

    0
    PitzKey
    Participant
    US
    Hi,

    Just following up on this, do you need me to test anything further?

    (The lack of this feature is preventing us from migrating a couple of ‘critical use’ PBXs)

    Thanks

    0
Viewing 15 replies - 1 through 15 (of 15 total)

Tagged: 

  • You must be logged in to reply to this topic.