Fresh install VitalPBX 2.4.0-3 and Asterisk 16.6.2 on VMWare crashed

VitalPBX Community Support General Discussion Fresh install VitalPBX 2.4.0-3 and Asterisk 16.6.2 on VMWare crashed

Up
0
Down
  • Post
    scdhome
    Participant

    Dear Forum,

    After a few (night) hours a fresh installation on VMware server the software crashed.
    It seems a known Asterisk problem in combination with CentOS 7.x
    The next errors where seen insite the ‘all’ log.
    You can call outside, but you are not receiving any call.
    Only the restart of the Asterisk services will help for a short moment.
    Any help will be fine:

    The error messenges:

    [2020-01-08 09:16:09] WARNING[14941] loader.c: Some non-required modules failed to load.
    [2020-01-08 09:16:09] ERROR[14941] loader.c: Error loading module ‘res_hep_pjsip.so’, missing dependency: res_hep
    [2020-01-08 09:16:09] ERROR[14941] loader.c: Error loading module ‘res_pjsip_phoneprov_provider.so’, missing dependency: res_phoneprov
    [2020-01-08 09:16:09] ERROR[14941] loader.c: res_pjsip_dialog_info_digium_body_supplement declined to load.
    [2020-01-08 09:16:09] ERROR[14941] loader.c: res_ari declined to load.
    [2020-01-08 09:16:09] ERROR[14941] loader.c: Declined modules which depend on res_ari: res_ari_asterisk, res_ari_recordings, res_ari_events, res_ari_applications, res_ari_device_states, res_ari_endpoints, res_ari_channels, res_ari_sounds, res_ari_bridges, res_ari_playbacks
    [2020-01-08 09:16:09] ERROR[14941] loader.c: res_pjsip_transport_websocket declined to load.
    [2020-01-08 09:16:09] ERROR[14941] loader.c: res_pjsip_notify declined to load.
    [2020-01-08 09:16:09] ERROR[14941] loader.c: Failed to resolve dependencies for res_http_media_cache
    [2020-01-08 09:16:09] ERROR[14941] loader.c: res_http_media_cache declined to load.
    [2020-01-08 09:16:09] ERROR[14941] loader.c: app_alarmreceiver declined to load.
    [2020-01-08 09:16:09] ERROR[14941] loader.c: app_festival declined to load.
    [2020-01-08 09:16:09] ERROR[14941] loader.c: func_odbc declined to load.

    Regards

     

    0
Viewing 3 replies - 1 through 3 (of 3 total)
  • Replies

    There are various reports about issues with VMWare servers. I recommend you to use a VPS like Vultr, Digital Ocean, or use a virtual machine app like VirtualBox.

    0
    scdhome
    Participant

    Dear,
    More specific .. I use the VMware ESXi, 6.0 server
    Will that give the same errors ?

    For VirualBox ( I will make a test install) I need extra hardware to run .. the ESXI server will have disk space enough.

    0
    scdhome
    Participant

    It seems that these errors are not conflicted with reach of the PBX. An Sip 403 error is staying on the software .. I looking arround to find out the error … incoming calls will not work .. same on hardware and on VMWare systems !!

    0
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.