Grandstream Gateway GXW410X

VitalPBX Community Support General Discussion Grandstream Gateway GXW410X

Up
0
Down
  • Post
    palacecomputers
    Participant

    Hi,

     

    Trying to setup a test PBX first time at doing this.  We have bought a GXW410X gateway for FXO lines.  Can not seem to understand.

    Process need to add to VitalPBX.

    Some of the other PBX’s I downloaded and tried had wizards for adding Gateways like this one.

    Any help would be appreciated.

    We are trying to decide if going into the VOIP Phone system business is worth it.

    This VitalPBX looked like one of the cleanest designs.  But I have alot to learn yet.

    Greg

    0
Viewing 15 replies - 1 through 15 (of 16 total)
  • Replies

    You must to create trunks between VPBX and the Grandstream gateway. I am attaching you an example.

    type=friend
    qualify=yes
    secret=password
    host=GRANDSTREAM_IP
    port=5060
    dtmfmode=rfc2833
    canreinvite=no
    disallow=all
    allow=ulaw
    0
    palacecomputers
    Participant

    Ok calls go in and out.

    Now can’t figure out how to get vitalpbx to change buttons on phone.  I think it may be setting on phone but not sure.

    Man do I have alot of terminology to learn.

    Any guidance would be helpful.  We have Grandstream phones we are testing with.

    Greg

    0

    Are you talking about Auto provisioning(End point manager)?

    0
    palacecomputers
    Participant

    Yes Endpoint.  We have used the template for the Grandstream phone but buttons do not seem to program.  I’m either missing a setting i have to manually change on phone or just don’t understand at all.

    I have set buttons in template to variuos settings but phone seems to only be programable at the local level for buttons.

    Greg

    0

    You must to assign the devices and the template to your Grandstream devices through the device mapping module, then, you must to reboot your phone.

    If doesn’t get provisioned, you must to define the provisioning URL  in the phone (example attached)

    0
    palacecomputers
    Participant

    Ok so my PBX is 192.168.0.11 would that be all I need to enter in the Config Server Path.

    I have tried this but if i need something else please advice.

     

    0
    palacecomputers
    Participant

    New question,  Have made progress in my understanding of the PBX.

    I would like to have my first few buttons actually represent phone lines like an old Analog system PBX.

    This would allow a line to be put on hold and someone else see it flashing and pickup.

    Is this pausible.  Thanks

    0

    Are you talking about hints?

    0
    toxicfusion
    Participant

    create device template and configure your BLF keys as lines. and or BLF keys for monitoring extensions.

     

     

    0
    palacecomputers
    Participant

    Ok got all this working.  Next I’m trying to Intercom or Page another extension.

    I created a code 1105 thats under Intercom and connected it to 1005 extension.  when I dial 1105 the 1005 rings instead of answers.

    I have check marked under ext 1005 to auto answer on intercom.  These are grandstream 2170 phones.

    Thanks for any help.

    0
    toxicfusion
    Participant

    For grandstream phones (they’re odd).  I perosnally stopping using them for clients due to quirks. Older generations were much better

     

    anyways – you’ll have to create an intercom BLF on the phone. So have to probably modify the config on provisioning template for intercom or find right code to use

     

    can also modify the DSS keys within the phone WebUI and manually define it

     

    set it for intercom and specify 1105. Save and test.  Ofcourse auto-answer has to be on for all the phones

     

    for intercom to work, has to be more than a single phone. So 1005 would be the destinations phone(s) and not same phone dialing from?

    0
    palacecomputers
    Participant

    What phone models do you like?

    0
    toxicfusion
    Participant

    The Grandstream gateway devices are fine.  Again, this is all user preference…    I use alot of Yealink, SNOM and Fanvil.

    Any luck with the phone and intercom feature?

    0

    To enable the Paging and Intercom, you must to set the “Internal Auto Answer” field to “intercom” on the desired extensions, also you must to configure the grandstream phones to allow the auto answer feature.

    In other hand, some Grandstream phones has the “MulticastRTP” option, this feature allows you to make paging in  a easy way.

    0
    palacecomputers
    Participant

    I would like to verify that my trunk is using RFC2833.  But I can’t switch it to text mode now when I select to edit it.  Where can i find this setting.

     

    0
Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.