How do I get a demo license for the VitXi Licensing Server

VitalPBX Community Support VitXi WebRTC How do I get a demo license for the VitXi Licensing Server

  • Post
    DannyLarsen
    Participant
    none
    Up
    4
    Down
    ::
    Trying to test the WebRTC
    Ver 3.0.4-4
    In the addon module when I click on Buy License the buy link goes to a bad link and the Activate link does not work without a license code
    Can you help
    1
Viewing 7 replies - 1 through 7 (of 7 total)
  • Replies
    DannyLarsen
    Participant
    none
    Up
    0
    Down
    ::
    Still having a few issues getting the web client to connect to a pjsip extension here is a screen shot if anyone could help
    Thanks
    Attachments:
    You must be logged in to view attached files.
    1
    Maynor Peralta
    Keymaster
    US
    Up
    0
    Down
    ::
    Hello Mr. Larsen,

    Verify that port 8089 is open. You can check if it is accessible by going to: https://your-server:8089/ws . If the port is accessible, you will see the following message: “not found”.

    You must also disable the SIP websocket in the “SIP Settings” module.

    You can view our documentation and check that you have the correct settings: https://wiki.vitalpbx.org/documentation/vitxi-webrtc/vitalpbx-preparations/

    Best regards!

    0
    DannyLarsen
    Participant
    none
    Up
    1
    Down
    ::
    I have followed the instructions in the vitalpbx preparations wiki
    I have also disabled the SIP websocket
    Could it be the Let’s Encrypt is creating an outdated certificate? After creation it is showing an expiration date of 1969
    Attachments:
    You must be logged in to view attached files.
    1
    Maynor Peralta
    Keymaster
    US
    Up
    0
    Down
    ::
    This is probably the problem. Are you already trying to create the certificate again?
    1
    DannyLarsen
    Participant
    none
    Up
    0
    Down
    ::
    Yes however I manually removed it from the directory /usr/share/vitalpbx/certificates/ before re creating it
    0
    DannyLarsen
    Participant
    none
    Up
    0
    Down
    ::
    I solved this issue by importing my own custom certificate, Using the lets encrypt would not create a certificate with a correct date setting always comes up as 1969 date
    0
    Up
    1
    Down
    ::
    You must disable the Geo firewall before generating Let’s Encrypt certificates, and also make sure to allow the access to the port 80, because Let’s Encrypt use this port for HTTP challenging.
    1
Viewing 7 replies - 1 through 7 (of 7 total)
  • The forum ‘VitXi WebRTC’ is closed to new topics and replies.