How to change SIP user agent?

VitalPBX Community Support General Discussion How to change SIP user agent?

Up
0
Down
  • Post
    ICTALL
    Participant

    When my trunk has registered, my provider shows my SIP user agent as: VitalPBX
    I want to change it to something else.

    Can this be done via the GUI or most I edit a conf file?

     

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • Replies

    Yes, you may change the user agent using the custom tab on SiP settings module

    0
    ICTALL
    Participant

    I went to Settings -> Technology Settings -> SIP Settings and tab: CUSTOM

    https://imgur.com/a/PI6e4Xu

    What parameter and value must I add to change the SIP user agent?

    0

    Parameter: useragent 

    Value: Asterisk PBX

     

    0
    ICTALL
    Participant

    I made sure my trunk was unregistered any more at my provider.
    Added Parameter: useragent  and Value: Asterisk PBX
    https://imgur.com/gA3CGAC

    Tried this serveral time, even renamed parameter once to sipuseragent 
    (did a save/update and reload after every change!)

    But my trunk provider keep showing SIP user agent: VitalPBX
    https://imgur.com/a/kOog9WR

    So, are you really really really really sure? ? 

     

    0

    Yes, I am sure. However, I checked the code, and this custom setting is overwritten by the VitalPBX

    0
    ICTALL
    Participant

    A Google search indicate that this could be change in etc/asterisk/sip_general_custom.conf

    Would this be a problem to change it in this config file?
    could it brake anything?

     

     

     

    0

    Do the following:

    • Go to the linux console
    • Go to the following path: /etc/asterisk/ombutel
    • Create a file with the following name: sip__20-general.conf
    • Add the following content to the file
    [general](+)
    useragent=Asterisk PBX
    • Save the file and reload asterisk configurations
    asterisk -rx"core reload"
    0
Viewing 7 replies - 1 through 7 (of 7 total)

Tagged: , , , ,

  • You must be logged in to reply to this topic.