INBOUND CALLS NOT AUTHORIZED

VitalPBX Community Support General Discussion INBOUND CALLS NOT AUTHORIZED

Up
0
Down
  • Post
    andrewbyrd70
    Participant

    I left all fields blank on the incoming route to accept any DID

    Here is the asterisk log of a call that does not come through

    <— Transmitting SIP response (550 bytes) to UDP:52.41.52.34:5060 —>
    SIP/2.0 401 Unauthorized
    Via: SIP/2.0/UDP 52.41.52.34:5060;rport=5060;received=52.41.52.34;branch=z9hG4bK622b.90d7b545000000000000000000000000.0
    Call-ID: 04191e3b36340dff-24732@0.0.0.0
    From: <sip:hi@52.41.52.34>;tag=64ff6b492a7d9ab14de1f0b7c15c9c17-0a32
    To: <sip:66.42.84.161>;tag=z9hG4bK622b.90d7b545000000000000000000000000.0
    CSeq: 10 OPTIONS
    WWW-Authenticate: Digest realm=”asterisk”,nonce=”1542830991/f04ca073c18c6f8c48e62f091631e4dd”,opaque=”27b988253ffbdd9f”,algorithm=md5,qop=”auth”
    Server: Asterisk PBX 13.23.1
    Content-Length: 0

     

    52.41.52.34 is the IP address of my originator

     

    Attached is the screen shot of my incoming route

     

    0
Viewing 15 replies - 1 through 15 (of 18 total)
  • Replies

    Are You using the same dialplan numeration in both servers? 

    0
    andrewbyrd70
    Participant

    Yes, it is sending 11 digits to my server

    0

    What is the status of the trunk? is already registered?

    Are you connected to a VoiP provider or another local server?

    Did you see any activity in the server who receive the call?

    0
    andrewbyrd70
    Participant

    Yes, the trunk is registered (see below)

    Endpoint: SKYETEL-INBOUND-SE Not in use 0 of inf
    Aor: SKYETEL-INBOUND-SE 0
    Contact: SKYETEL-INBOUND-SE/sip:SKYETEL-INBOUND-SE@ 47d5b4590b Avail 14.791
    Transport: transport-udp udp 0 0 0.0.0.0:5062

     

    Activity on my server hosting VitalPBX

     

    <— Transmitting SIP response (482 bytes) to UDP:69.85.122.148:5062 —>
    SIP/2.0 401 Unauthorized
    Via: SIP/2.0/UDP 192.168.10.78:5062;rport=5062;received=69.85.122.148;branch=z9hG4bK-c517874
    Call-ID: 484a29e1-8ceeb3ab@192.168.10.78
    From: <sip:201@66.42.84.161>;tag=a4b25e87d7c3995a
    To: <sip:201@66.42.84.161>;tag=z9hG4bK-c517874
    CSeq: 1001 SUBSCRIBE
    WWW-Authenticate: Digest realm=”asterisk”,nonce=”1542830994/c8ebbce77ed87b9093c6d0883c3a09c5″,opaque=”3c37b8c45aab1cf3″,algorithm=md5,qop=”auth”
    Server: Asterisk PBX 13.23.1
    Content-Length: 0

     

    I am connected to Skyetel.  They confirm that my vitalpbx server is sending back 401 / unauthorized

    0

    Try to create an inbound route with an specific DID

    0
    andrewbyrd70
    Participant

    i tried but no success

     

    see attached

    0

    Try to enable the “Allow guest” option under SIP settings (Settings >> Technology Settings >> SIP Settings)

    0
    oromero31
    Participant

    You should run verify that number is reaching the vitalPBX, as it seems this anonymous test is going to activate what I put in the image and tell us what happens. 

    0
    andrewbyrd70
    Participant

    I enabled “Allow Guests”  No luck

    <— Transmitting SIP response (484 bytes) to UDP:69.85.122.148:5062 —>
    SIP/2.0 401 Unauthorized
    Via: SIP/2.0/UDP 192.168.10.78:5062;rport=5062;received=69.85.122.148;branch=z9hG4bK-9c8ff4cf
    Call-ID: 6542803f-52693031@192.168.10.78
    From: <sip:201@66.42.84.161>;tag=a4b25e87d7c3995a

     

    Vital PBX is rejecting the incoming call.  I did verify the number is reaching the PBX
    To: <sip:201@66.42.84.161>;tag=z9hG4bK-9c8ff4cf
    CSeq: 1001 SUBSCRIBE
    WWW-Authenticate: Digest realm=”asterisk”,nonce=”1542834310/6c8e30da4752811c930f554857ebe6a3″,opaque=”1289bc7452eb39fe”,algorithm=md5,qop=”auth”
    Server: Asterisk PBX 13.23.1
    Content-Length: 0

    0

    Did you setup the port 5060 in your trunk configuration?

    0
    andrewbyrd70
    Participant

    Yes, I have 5060 on the SKyetel originator side and 5060 on the inbound trunk

    see attached

    0
    oromero31
    Participant

    But, Trunk is PJSIP you have to use 5062?

     

    0

    I guess this is why is failing:

    From: <sip:201@66.42.84.161>;tag=a4b25e87d7c3995a
    To: <sip:201@66.42.84.161>;tag=z9hG4bK-c517874

    It says that comes from 201 and is dialing 201??

    0
    andrewbyrd70
    Participant

    I tried that – I changed the provider side to 5062 and the trunk in VitalPbx to 5062.  Same results

    In Freepbx I use PJSIP trunks but I have 5060 for the originator. works fine

     

    0
    andrewbyrd70
    Participant

    Now I am totally confused.  I guess I will have to just think on this awhile.  Thanks for your help

    0
Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.