Inbound Calls Not Working — No Route Exists — After Patch 2.0.4-1

VitalPBX Community Support General Discussion Inbound Calls Not Working — No Route Exists — After Patch 2.0.4-1

  • Post
    mikebronner
    Participant

      > 0x7f4e3400d430 — Strict RTP learning after remote address set to: 74.120.93.202:52408
        — Executing [16266714300@default-trunk:1] Gosub(“SIP/xxxxxxxx-00000001”, “sub-check-blacklist,s,1(98cc244096f60a76,+16263782270)”) in new stack
        — Executing [s@sub-check-blacklist:1] NoOp(“SIP/xxxxxxxx-00000001”, “Testing if +16263782270 is in Black List”) in new stack
        — Executing [s@sub-check-blacklist:2] GotoIf(“SIP/xxxxxxxx-00000001”, “0?banned”) in new stack
        — Executing [s@sub-check-blacklist:3] Return(“SIP/xxxxxxxx-00000001”, “”) in new stack
        — Executing [16266714300@default-trunk:2] Gosub(“SIP/xxxxxxxx-00000001”, “sub-setup-call-type,s,1(incoming)”) in new stack
        — Executing [s@sub-setup-call-type:1] NoOp(“SIP/xxxxxxxx-00000001”, “Determinating Call Type”) in new stack
        — Executing [s@sub-setup-call-type:2] GotoIf(“SIP/xxxxxxxx-00000001”, “0?return”) in new stack
        — Executing [s@sub-setup-call-type:3] Gosub(“SIP/xxxxxxxx-00000001”, “s-incoming,1()”) in new stack
        — Executing [s-incoming@sub-setup-call-type:1] NoOp(“SIP/xxxxxxxx-00000001”, “Incoming Call”) in new stack
        — Executing [s-incoming@sub-setup-call-type:2] Set(“SIP/xxxxxxxx-00000001”, “__CALL_TYPE=2”) in new stack
        — Executing [s-incoming@sub-setup-call-type:3] Return(“SIP/xxxxxxxx-00000001”, “”) in new stack
        — Executing [s@sub-setup-call-type:4] Set(“SIP/xxxxxxxx-00000001”, “__CALL_TYPE_CONFIGURED=yes”) in new stack
      — Executing [s@sub-setup-call-type:5] Set(“SIP/xxxxxxxx-00000001”, “CDR(calltype)=2”) in new stack
        — Executing [s@sub-setup-call-type:6] Return(“SIP/xxxxxxxx-00000001”, “”) in new stack
        — Executing [16266714300@default-trunk:3] Goto(“SIP/xxxxxxxx-00000001”, “incoming-calls,16266714300,1”) in new stack
        — Goto (incoming-calls,16266714300,1)
        — Channel ‘SIP/xxxxxxxx-00000001’ sent to invalid extension: context,exten,priority=incoming-calls,16266714300,1
        — Executing [i@incoming-calls:1] NoCDR(“SIP/xxxxxxxx-00000001”, “”) in new stack
        — Executing [i@incoming-calls:2] Goto(“SIP/xxxxxxxx-00000001”, “invalid-dest,s,1”) in new stack
        — Goto (invalid-dest,s,1)
      — Executing [s@invalid-dest:1] NoOp(“SIP/xxxxxxxx-00000001”, “Invalid Route to Dial”) in new stack
        — Executing [s@invalid-dest:2] Playback(“SIP/xxxxxxxx-00000001”, “im-sorry&no-route-exists-to-dest&vm-goodbye”) in new stack
           > 0x7f4e3400d430 — Strict RTP switching to RTP target address 74.120.93.202:52408 as source
        — <SIP/xxxxxxxx-00000001> Playing ‘im-sorry.ulaw’ (language ‘en’)
        — <SIP/xxxxxxxx-00000001> Playing ‘no-route-exists-to-dest.ulaw’ (language ‘en’)
        — <SIP/xxxxxxxx-00000001> Playing ‘vm-goodbye.ulaw’ (language ‘en’)

    I’ve just applied patch 2.0.4-2, and the problem persists. I have checked the inbound routes, and the destination is set correctly. The relevant extension is also configured. I have tried setting various destinations on the inbound route, all elicit the same response (shown above). I also deleted all inbound routes and recreated them from scratch, to no avail. Any ideas what’s happening here? Thanks!

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • Replies
    Up
    0
    Down

    What is your DID?

    0
    mikebronner
    Participant
    Up
    0
    Down

    16266714300

    0
    mikebronner
    Participant
    Up
    0
    Down

    It looks like either the update wiped out my number from the inbound route DID field, or it now requires it. Either way, adding my DID to the inbound route seems to have fixed things.

    0
    Up
    0
    Down

    We regret the inconveniences, it is an error of the update but we could not detect why, apparently it happens with certain configurations, we have tried to simulate this error, but we have not had success

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.