Inbound faxes disappearing

VitalPBX Community Support General Discussion Inbound faxes disappearing

  • Post
    kbohannon
    Participant
    Up
    0
    Down

    I’ve been struggling with the fax module. I have an inbound route pointed directly at my (8th) virtual fax device. Inbound faxes, according to the sender, are successful. Watching asterisk -rvvv shows the call in progress. But then, nothing. Nothing in the fax viewer, nothing via email, nothing in /var/lib/ombutel/fax/recd.

    — Executing [17135555555@incoming-calls:5] Set(“SIP/sip.telnyx.com-00000009”, “FAX_DEST_CONT=app-virtual-faxes”) in new stack
    — Executing [17135555555@incoming-calls:6] Set(“SIP/sip.telnyx.com-00000009”, “FAX_DEST_EXT=VFAX-8”) in new stack
    — Executing [17135555555@incoming-calls:7] Set(“SIP/sip.telnyx.com-00000009”, “FAX_DEST_PRIO=1”) in new stack
    — Executing [17135555555@incoming-calls:8] Set(“SIP/sip.telnyx.com-00000009”, “FAXOPT(faxdetect)=yes”) in new stack
    — Executing [17135555555@incoming-calls:9] Answer(“SIP/sip.telnyx.com-00000009”, “”) in new stack
    — Executing [17135555555@incoming-calls:10] Wait(“SIP/sip.telnyx.com-00000009”, “5”) in new stack
    == Redirecting ‘SIP/sip.telnyx.com-00000009’ to fax extension due to CNG detection
    == Spawn extension (incoming-calls, fax, 1) exited non-zero on ‘SIP/sip.telnyx.com-00000009’
    — Executing [fax@incoming-calls:1] NoOp(“SIP/sip.telnyx.com-00000009”, “Fax Detected”) in new stack
    — Executing [fax@incoming-calls:2] Set(“SIP/sip.telnyx.com-00000009”, “FAXOPT(faxdetect)=no”) in new stack
    — Executing [fax@incoming-calls:3] Goto(“SIP/sip.telnyx.com-00000009”, “app-virtual-faxes,VFAX-8,1”) in new stack
    — Goto (app-virtual-faxes,VFAX-8,1)
    — Executing [VFAX-8@app-virtual-faxes:1] NoOp(“SIP/sip.telnyx.com-00000009”, “Dialing Fax Modem: ttyIAX8”) in new stack
    — Executing [VFAX-8@app-virtual-faxes:2] Set(“SIP/sip.telnyx.com-00000009”, “FAXOPT(faxdetect)=no”) in new stack
    — Executing [VFAX-8@app-virtual-faxes:3] Dial(“SIP/sip.telnyx.com-00000009”, “IAX2/ttyIAX8/17135555555”) in new stack
    — Called IAX2/ttyIAX8/17135555555
    — Call accepted by 127.0.0.1:3570 (format ulaw)
    — Format for call is (ulaw)
    — IAX2/ttyIAX8-6966 is ringing
    — IAX2/ttyIAX8-6966 answered SIP/sip.telnyx.com-00000009
    — Channel IAX2/ttyIAX8-6966 joined ‘simple_bridge’ basic-bridge <9d1e9dbc-0280-468d-b266-f6e7487de856>
    — Channel SIP/sip.telnyx.com-00000009 joined ‘simple_bridge’ basic-bridge <9d1e9dbc-0280-468d-b266-f6e7487de856>

    Kerry Bohannon
    Amicus Voice, LLC

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • Replies
    Up
    0
    Down

    You may find the faxes log in the following path: /var/spool/hylafax/log/

    0
    kbohannon
    Participant
    Up
    0
    Down

    @ing-joserivera26

    In that directory I see only a collection of “c0000000##” files of about 9-12k each. 

    Kerry Bohannon
    Amicus Voice, LLC

    0
    Up
    0
    Down

    Check the last file created, it contains all the log of received/send faxes. One file is created per fax.

    0
    kbohannon
    Participant
    Up
    0
    Down

    I just took the easy path and did a backup and restore to a fresh install. That did the trick. A couple of other issues I ran into as a result, but I will post them in a separate topic.

    Kerry Bohannon
    Amicus Voice, LLC

    0
Viewing 4 replies - 1 through 4 (of 4 total)

Tagged: 

  • The topic ‘Inbound faxes disappearing’ is closed to new replies.