Inbound issue pjsip – Outbound is fine

VitalPBX Community Support General Discussion Inbound issue pjsip – Outbound is fine

  • Post
    andrewbyrd70
    Participant

    Created pjsip ext 102 – Use Skyetel for inbound.  Changed port on Skyetel end to 5062 since I am using all pjsip for trunks and extensions

    Outbound calling works fine

    I have DID 678-xxx-1700 directed to ext 102

    Goes straight to Voice Mail even though ext shows registered and outbound calls work fine from ext 102

    Here are the logs when an inbound is attempted

     

    Connected to Asterisk 16.5.0 currently running on netphoneusa (pid = 3040)
    [2019-08-16 18:44:54] ERROR[28105]: res_pjsip.c:3533 ast_sip_create_dialog_uac: Endpoint ‘102’: Could not create dialog to invalid URI ‘102’. Is endpoint registered and reachable?
    [2019-08-16 18:44:54] ERROR[28105]: chan_pjsip.c:2509 request: Failed to create outgoing session to endpoint ‘102’
    [2019-08-16 18:44:54] WARNING[1194][C-00000047]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route to destination)

     

    I created a custom destination to my cell phone.  That works fine.  When I dial the DID 678-xxx-1700 it goes through vitalpbx and to my cell phone.

    So the problem must be with the extension itself.  I have the port in the ext set to 5062 on a Yealink T-29

     

    Any ideas?

    0
Viewing 15 replies - 1 through 15 (of 28 total)
  • Replies
    Up
    0
    Down

    Go to the Asterisk CLI, execute the following command and post the output.

    pjsip show endpoints
    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    It appears that even though I have it set for 5062 it is trying to use 5060

     

    Endpoint: 102/102 Unavailable 0 of inf
    InAuth: auth102/102
    Aor: 102 1
    Contact: 102/sip:102@192.168.5.41:5060 3420119a23 Unavail nan
    Transport: transport-udp udp 0 0 0.0.0.0:5062

    Endpoint: ADMIN-2 Unavailable 0 of inf
    Aor: ADMIN-2 0
    Contact: ADMIN-2/sip:ADMIN-2@64.136.173.22:5058 3574848a6b Unavail nan
    Transport: transport-udp udp 0 0 0.0.0.0:5062

    Endpoint: ADMIN1 Not in use 0 of inf
    Aor: ADMIN1 0
    Contact: ADMIN1/sip:ADMIN1@64.136.174.30:5060 e084729b30 Avail 30.804
    Transport: transport-udp udp 0 0 0.0.0.0:5062

    Endpoint: admin Unavailable 0 of inf
    Aor: admin 0
    Contact: admin/sip:admin@term.skyetel.com:5062 4a49b8c81e Unavail nan
    Transport: transport-udp udp 0 0 0.0.0.0:5062

    Endpoint: admin2 Unavailable 0 of inf
    Aor: admin2 0
    Contact: admin2/sip:admin2@52.41.52.34:5062 5e87dd92df Unavail nan
    Transport: transport-udp udp 0 0 0.0.0.0:5062

    Endpoint: admin3 Unavailable 0 of inf
    Aor: admin3 0
    Contact: admin3/sip:admin3@52.8.201.128:5062 6b224fd172 Unavail nan
    Transport: transport-udp udp 0 0 0.0.0.0:5062

    Endpoint: admin4 Unavailable 0 of inf
    Aor: admin4 0
    Contact: admin4/sip:admin4@52.60.138.31:5062 f95b182b96 Unavail nan
    Transport: transport-udp udp 0 0 0.0.0.0:5062

    Endpoint: admin5 Unavailable 0 of inf
    Aor: admin5 0
    Contact: admin5/sip:admin5@50.17.48.216:5062 613b2e601b Unavail nan
    Transport: transport-udp udp 0 0 0.0.0.0:5062

    Objects found: 9

    [2019-08-16 19:15:10] NOTICE[31884]: res_pjsip/pjsip_distributor.c:676 log_faile d_request: Request ‘OPTIONS’ from ‘<sip:hi@52.41.52.34>’ failed for ‘52.41.52.34 :5060’ (callid: 6e077e203df43aaf-5908@0.0.0.0) – No matching endpoint found
    [2019-08-16 19:15:22] NOTICE[28105]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@52.60.138.31>’ failed for ‘52.60.138.31:5060’ (callid: 7715d6df7ee7b86a-17006@0.0.0.0) – No matching endpoint found
    [2019-08-16 19:15:35] NOTICE[31884]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@52.8.201.128>’ failed for ‘52.8.201.128:5060’ (callid: 7ee79a9a62edb4d2-1034@0.0.0.0) – No matching endpoint found
    [2019-08-16 19:15:40] NOTICE[28105]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@50.17.48.216>’ failed for ‘50.17.48.216:5060’ (callid: 008e5a861ab8f848-30306@0.0.0.0) – No matching endpoint found
    [2019-08-16 19:15:40] NOTICE[31884]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@52.41.52.34>’ failed for ‘52.41.52.34:5060’ (callid: 6e077e203df43ea6-5908@0.0.0.0) – No matching endpoint found
    [2019-08-16 19:15:53] NOTICE[31884]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@52.60.138.31>’ failed for ‘52.60.138.31:5060’ (callid: 7715d6df7ee7bc61-17006@0.0.0.0) – No matching endpoint found

    0
    Up
    0
    Down

    This how you must register a phone with PJSIP (check the picture attached).

    If the phone doesn’t have the port field, you may put the IP Address or Server Address in the following format: 0.0.0.0:5062

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    This is one of my trunks set up for inbound.  I already made sure on the skyetel (provider) that it is set to 5062 on their end.  But for some reasons the logs show that it is trying to communicate with the provider via port 5060

    [2019-08-16 15:55:10] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@52.8.201.128>’ failed for ‘52.8.201.128:5060’ (callid: 7ee79a9a62eed692-1034@0.0.0.0) – No matching endpoint found

     

    0
    Up
    0
    Down

    I am attaching the configuration of a Skytel Trunk

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    I did specify port 5062 in the yealink

     

    see attachment

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    I see your image of the Skyetel trunk, but you show port 5060 in the skyetel trunk.  It should be 5062 since I am using pjsip, correct?  So I have it set for 5062 on the skyetel portal endpoint and on the trunk in Vitalpbx

    0
    Up
    0
    Down

    It is port 5062 on Skytle side, and 5060 on VitalPBX side

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    I changed the port on the vital side to 5060  (see pic)

    The logs still show this:

     

    [2019-08-16 16:19:11] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@52.60.138.31>’ failed for ‘52.60.138.31:5060’ (callid: 7715d6df7ee9a827-17006@0.0.0.0) – No matching endpoint found
    [2019-08-16 16:19:16] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@52.8.201.128>’ failed for ‘52.8.201.128:5060’ (callid: 7ee79a9a62ef90bc-1034@0.0.0.0) – No matching endpoint found
    [2019-08-16 16:19:20] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@52.41.52.34>’ failed for ‘52.41.52.34:5060’ (callid: 6e077e203df61a90-5908@0.0.0.0) – No matching endpoint found
    [2019-08-16 16:19:27] NOTICE[15472]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘OPTIONS’ from ‘<sip:hi@50.17.48.216>’ failed for ‘50.17.48.216:5060’ (callid: 008e5a861abae805-30306@0.0.0.0) – No matching endpoint found

     

    All those IP addresses above are the Skyetel IP addresses

     

    See attachments – one shows my trunk info in vital and the other shows my set up for the endpoint in skyetel

     

     

    0
    Up
    0
    Down

    you didn’t define the match field.

    Match:  Due that the Skyetel traffic comes from random IP addresses, we will add all the valid IP addresses provided by the Skyetel documentation (52.41.52.34,52.8.201.128,52.60.138.31,50.17.48.216,35.156.192.164)

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    I set up each IP address from skyetel as its own individual trunk. I don’t use them for termination just origination. a long time ago I set it up this way in at work fine but for some reason it won’t now. Again I just set up each IP address under its own trunk as opposed to trying to use the match

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    I’m still not sure why on the skyetel trunks you would use port 5060 when I’m setting everything up PJsip as 5062 on the skyetel and 5062 in the phone itself I’m not sure why I would use 5060 in the actual Trunk

    0
    Up
    0
    Down

    For registering to skyetel you must use 5060 because that is the port that skyetel and other providers use. But, due, PJSIP on VitalPBX is set to use the port 5062, when Skyetel sends the authentication to your PBX, must to do it through the port 5062.

    • PBX —> To Skyetel (5060)
    • Skyetel —> To PBX (5062)
    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    Still not working.  Here is what I did

    1)  I deleted all trunks except the one term.skyetel.com  

    2)  I changed the port to 5060

    3)  I added the match IP addresses   

    (See image attached)

     

    I have DID 678-345-1700 from Skyetel pointed to ext 102

     

    Ext 102 is on a Yealink T29G.

    I made sure the port in the T29G is 5062

     

    When I dial the 678-345-1700 I get the voice mail for ext 102.  If I change the destination to my cell phone using custom destination it works.  That tells me the DID is reaching the server.  I just can’t figure why it won’t ring the yealink and goes straight to voice mail

    When I try to dial the DID linked to the yealink, this is what the log says . . .

     

    [2019-08-16 21:39:25] ERROR[15472]: res_pjsip.c:3533 ast_sip_create_dialog_uac: Endpoint ‘102’: Could not create dialog to invalid URI ‘102’. Is endpoint registered and reachable?
    [2019-08-16 21:39:25] ERROR[15472]: chan_pjsip.c:2509 request: Failed to create outgoing session to endpoint ‘102’
    [2019-08-16 21:39:25] WARNING[11872][C-00000060]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route to destination)
    [2019-08-16 21:39:25] ERROR[3387]: res_pjsip.c:3533 ast_sip_create_dialog_uac: Endpoint ‘102-2’: Could not create dialog to invalid URI ‘102-2’. Is endpoint registered and reachable?
    [2019-08-16 21:39:25] ERROR[3387]: chan_pjsip.c:2509 request: Failed to create outgoing session to endpoint ‘102-2’
    [2019-08-16 21:39:25] WARNING[11872][C-00000060]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route to destination)

    The issue is why the yealink is not ringing, instead of going straight to VM

    BTW – I can make outbound calls (using voip innovations as my termination) with no issues

     

     

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    What if I just change the PJSIP port in Vitalpbx to 5060?  Would that fix all issues?

    0
Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Inbound issue pjsip – Outbound is fine’ is closed to new replies.