Inbound issue pjsip – Outbound is fine

VitalPBX Community Support General Discussion Inbound issue pjsip – Outbound is fine

  • Post
    andrewbyrd70
    Participant

    Created pjsip ext 102 – Use Skyetel for inbound.  Changed port on Skyetel end to 5062 since I am using all pjsip for trunks and extensions

    Outbound calling works fine

    I have DID 678-xxx-1700 directed to ext 102

    Goes straight to Voice Mail even though ext shows registered and outbound calls work fine from ext 102

    Here are the logs when an inbound is attempted

     

    Connected to Asterisk 16.5.0 currently running on netphoneusa (pid = 3040)
    [2019-08-16 18:44:54] ERROR[28105]: res_pjsip.c:3533 ast_sip_create_dialog_uac: Endpoint ‘102’: Could not create dialog to invalid URI ‘102’. Is endpoint registered and reachable?
    [2019-08-16 18:44:54] ERROR[28105]: chan_pjsip.c:2509 request: Failed to create outgoing session to endpoint ‘102’
    [2019-08-16 18:44:54] WARNING[1194][C-00000047]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route to destination)

     

    I created a custom destination to my cell phone.  That works fine.  When I dial the DID 678-xxx-1700 it goes through vitalpbx and to my cell phone.

    So the problem must be with the extension itself.  I have the port in the ext set to 5062 on a Yealink T-29

     

    Any ideas?

    0
Viewing 13 replies - 16 through 28 (of 28 total)
  • Replies
    Up
    0
    Down

    Can you call between extensions?

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    No, it goes straight to vm ext to ext

     

     

    [2019-08-16 22:07:57] ERROR[15472]: res_pjsip.c:3533 ast_sip_create_dialog_uac: Endpoint ‘104’: Could not create dialog to invalid URI ‘104’. Is endpoint registered and reachable?
    [2019-08-16 22:07:57] ERROR[15472]: chan_pjsip.c:2509 request: Failed to create outgoing session to endpoint ‘104’
    [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route to destination)

    0
    Up
    0
    Down

    So, your trunk is working fine, what is wrong is the registration of your phones. Are your phones behind Nat? Is your server in the cloud or local server?

    Are your phones in the same network of your PBX?

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    I have vitalpbx hosted on a vps from vultr

    I whitelisted in fail2ban and the firewall the IP addresses from where the phones are registering

     

    Current logs

     

    (Ihave 102 and 104 registered as pjsip ext)

     

    155.138.219.115 is my vultr server

     

    [2019-08-16 22:15:38] NOTICE[15472]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failednetphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:15:38] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failed netphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:15:38] NOTICE[15472]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failednetphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:15:38] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failed netphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:16:09] NOTICE[15472]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failednetphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:16:09] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failed netphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:16:09] NOTICE[15472]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failednetphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:16:09] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failed netphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route netphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:16:40] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failed netphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:16:40] NOTICE[15472]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failednetphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:16:40] NOTICE[3387]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failed netphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route [2019-08-16 22:16:40] NOTICE[15472]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘”VITALPBX” <sip:102@155.138.219.115>’ failednetphoneusa*CLI> [2019-08-16 22:07:57] WARNING[19552][C-00000068]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 – No route

    0
    Up
    0
    Down

    I assume that is something misconfigured in the server. You may try to use password without special characters, in case that your phone doesn’t support special characters.

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    I tried changing the password and even tried a cisco spa525g

    Would you be willing to login to my server, test it on your end?  This is not a production server yet.  I trust you with my credentials

    I would be most appreciative to solve this

    0
    Up
    0
    Down

    Send me the SSH and Web credentials to my email: miguel@vitalpbx.com

    I will check it for you!!!

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    I may have just found the issue

    When I go to SYSTEM SETTINGS > Network settings I get this:

    Error: NetworkManager is not running.

    0
    andrewbyrd70
    Participant
    Up
    0
    Down

    Shouldn’t the network manager settings autopopulate on installation?  I used the vps scripton the vitalpx download page to install it

    0
    leisser
    Participant
    Up
    0
    Down

    Can you make and receive calls with VoIP Innovations?

    Can you port the trunk setting?

    Thank you

    0
    Up
    0
    Down

    @andrewbyrd70

    The Network Manager doesn’t work on VPS, because the VPS providers don’t allow to alter its network configurations.

    0
    hlev
    Participant
    Up
    0
    Down

    @leisser Your issue now is NAT, if your extensions are not registering to the PBX they will not be able to receive any calls. Go into settings->profiles and then choose to either create a new profile for pjsip or just edit the default one. Set to YES, Force rport, Rewrite Contact and RTP symmetric

    Your extensions should be registering properly after that and you will get proper both way audio.

    0
    InTeleSync
    Participant
    Up
    0
    Down

    Note that if you set Settings -> Profiles -> Default PJSIP Profile WebRTC = Yes, then you’ll also lose audio.

    While we’re not currently using WebRTC, doesn’t mean it won’t be used in the future. 

     

    0
Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘Inbound issue pjsip – Outbound is fine’ is closed to new replies.