Incoming calls rejected with 403 forbidden

VitalPBX Community Support General Discussion Incoming calls rejected with 403 forbidden

  • Post
    Tom
    Participant

    Hi,

     

    I have a pbx running incrediblepbx-2.3.8-3.x86_64. It has a callcentric trunk and a voipms trunk that were working but for some reason that I cannot determine, they have stopped accepting incoming calls. Outgoing calls work as expected. Both trunks show registered on both the asterisk command line and the providers control panel.

    I have inbound routes setup for both trunks that were working. I am not sure what changed but sngrep shows 403 forbidden on the invite when I place a call. Can someone give me an idea how to troubleshoot this problem?

     

    SIP/2.0 403 Forbidden
    204.11.192.39:5060 192.168.0.7:5060 │Via: SIP/2.0/UDP 204.11.192.39:5060;branch=z9hG4bK-9771bc9eadc848eaa718deb8ae334112;
    ──────────┬───────── ──────────┬─────────│ceived=204.11.192.39;rport=5060
    │ INVITE (SDP) │ │From: <sip:1XXXXXXXXXX@66.193.176.35>;tag=3781623535-44806
    14:58:55.344179 │ ──────────────────────────> │ │To: <sip:18623200030@ss.callcentric.com>;tag=as6fdffe6a
    +0.002274 │ 403 Forbidden │ │Call-ID: 2775960-3781623535-44778@msw1.telengy.net
    14:58:55.346453 │ <────────────────────────── │ │CSeq: 1 INVITE
    +0.027690 │ ACK │ │Server: VitalPBX
    14:58:55.374143 │ ──────────────────────────> │ │Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, M
    +5.452484 │ ACK │ │SAGE
    14:59:00.826627 │ ──────────────────────────> │ │Supported: replaces, timer
    │ │ │Content-Length: 0

    0
Viewing 5 replies - 16 through 20 (of 20 total)
  • Replies
    Tom
    Participant
    Up
    0
    Down

    I figured it out! I had a sip domain set. Once I removed that, things started working again.

    Am I correct that I cannot set sip domains with registered trunks?

    0
    scdhome
    Participant
    Up
    0
    Down

    Dear Tom,
    I had the same problem .. just removed the record with the Sip domain name.
    The next 30 minutes I will test the connection again.
    Keep in contact.

    0
    scdhome
    Participant
    Up
    0
    Down

    Update .. to remove the Sip Domain name is NOT the solution .. it is somewhere else in the system.
    It seems not an asterisk error .. we have to search more …

    0
    scdhome
    Participant
    Up
    0
    Down

    Think I ‘found it’ place allowguest=yes in the advanced option of the ‘user’ .. of the trunk.
    This allow the quest calls to the software .. it will give NO security leak !

    0
    Up
    0
    Down

    I guess the problem is that providers like call centric sent the calls from random domains or IP address, so, when using SIP, you must create one trunk for each of those domains, if you use PJSIP, you must only define all the domains in the match field.

    0
Viewing 5 replies - 16 through 20 (of 20 total)
  • You must be logged in to reply to this topic.