Intercom and Paging

VitalPBX Community Support General Discussion Intercom and Paging

  • Post
    hlev
    Participant

    Setting up intercom and paging groups on the PBX, I cant seem to get Yealink phones to autoanswer. Calls are made to the phones as if they where a regular call. I have activated Internal Auto Answer on the extensions and Intercom Allow is set to Enabled on the Phones. Anything else that would need to be enabled to make the phones autoanswer?

    PBX is remote to the phones, only way for me so far to get paging working is setting up multicast IP directly on the phones.

    0
Viewing 15 replies - 1 through 15 (of 27 total)
  • Replies
    technomancer_101
    Participant
    Up
    0
    Down

    I’m afraid I don’t have a fix, however I will add I’ve been having the same issue with Grandstream phones with identical symptoms. I got one phone to auto-answer once, but I’ve never been able to reproduce that.

    For the time being, I’ve rolled out multicast paging, however with the lack of an “announcement tone” or a beep, it’s quite startling.

    0
    InTeleSync
    Participant
    Up
    0
    Down

    With factory defaulted Yealinks and using bare minimum auto provisioning from VitalPBX, our Yealinks pick up the SIP intercom/page as expected. 

    With same parameters for Grandstream phones, they will ring and not auto answer the SIP page.

     

    0
    Up
    0
    Down

    For using paging and auto-answer on different phone brands you must search for a setting like: “Allow Auto Answer by Call-Info” and enable it, in order that paging works as expected. check the picture attached

    0
    InTeleSync
    Participant
    Up
    0
    Down

    That is P298, which defaults to 0. Set to 1 and now paging works. The warning tone doesn’t play (on Yealinks nor Grandstreams), but not too worried about that just yet. Thanks.

     

     

    0
    hlev
    Participant
    Up
    0
    Down

    I have what I believe would be the equivalent on yealink phones which is Intercom Allowed, features.intercom.allow=1 (Enabled) , but still phones appear as not to be getting anything extra in the header as they don’t auto answer at all.

    Paging I can do via multicast ip on the phones directly, but intercom is what I am trying to get working. On freepbx I could do *80+extension number and that would work. *80 is set for hot desking in vital though, *82 which is for paging doesn’t work for me either.

    0
    InTeleSync
    Participant
    Up
    0
    Down

    @hiev, just to clarify… You’re attempting *82+extension number? or *82+Paging&Intercom Code?

    If your Paging&Intercom Code has multicast entries, then I assume it’ll use multicast and not SIP to page.

    Validate you’re running the latest Yealink firmware. Factory reset the phone and reregister with VitalPBX as a bare minimum, as features.intercom.allow=1 is the factory default anyways. See if that helps.

     

    0
    hlev
    Participant
    Up
    0
    Down

    @admin-2529

    *82+extension number  and dialing directly to the Paging and Intercom Code, both haven’t autoanswered.

    Will certainly try to upgrade the firmware of the phones to the lastest one and re-test as well.

    0
    hlev
    Participant
    Up
    0
    Down

    Yealink T46s phones, all updated to the latest firmware but still can’t get them to autoanswer the intercom calls.

    0
    hlev
    Participant
    Up
    0
    Down

    It doesn’t appear the system is sending any header to tell the phone to auto answer.

    0
    Up
    0
    Down

    Did you enable the Internal Auto-Answer parameter on the extensions under the advanced tab?

    0
    hlev
    Participant
    Up
    0
    Down

    @ing-joserivera26

    Yes internal auto answer is set to intercom on the extensions.

    0
    Up
    0
    Down

    Then, VitalPBX’s is sending the headers.

    0
    hlev
    Participant
    Up
    0
    Down

    @ing-joserivera26

    Shouldn’t I see the auto-answer somewhere in the invite using sngrep as well?

    0
    Up
    0
    Down

    Did you create a paging and intercom item with its respective dial code?

    picture attached.

     

    0
    hlev
    Participant
    Up
    0
    Down

    Hello @ing-joserivera26, yes the intercom item is created. Here is the screenshot of how its setup.

     

    0
Viewing 15 replies - 1 through 15 (of 27 total)

Tagged: 

  • The topic ‘Intercom and Paging’ is closed to new replies.