Loosing BLF indecation after a few minutes.

VitalPBX Community Support Reporting an Issue Loosing BLF indecation after a few minutes.

  • Post
    Gary
    Participant
    I have a cloud based serevr with remote phones connected directly and some through OpenVPN, Yealink, Fanvil & Htek phones, all of them have BLF buttons which work for a while after booted up but then they all stop getting BLF changes in state, a reboot of phones will start working but they will loose again after a few minutes. All phones are using PJSIP.

    DistroCentOS Linux release 7.8.2003 (Core)Kernel3.10.0-1127.19.1.el7.x86_64Asterisk17.7.0VitalPBX3.0.2-2

     

    0
Viewing 10 replies - 1 through 10 (of 10 total)
  • Replies
    Gary
    Participant
    Up
    0
    Down
    I am able to reproduce the problem, after rebooting all the phones the BLF’s work, as soon as I make a change on pbx and press red button to update all BLF’s stop working.
    0
    Gary
    Participant
    Up
    0
    Down
    I setup 1 phone as sip and it does not loose blf indecation apon reload so it looks like it is pjsip specific, is this a bug in Asterisk or Vitalpbx or pherhaps just my server.

     

    0
    Up
    0
    Down
    Did you try with another phone brand? We don’t have any reports about this issue, except yours.
    0
    Gary
    Participant
    Up
    0
    Down
    Yealink, Fanvil & Htek all phone have the same issue.

    I moved all phones to SIP and the problem is gone, it must be something with PJsip and hints not remaining after reload, I have a PJsip trunk from ClearlyIP and it works fine ?

     

    0
    Milton Brown
    Participant
    Up
    0
    Down
    I am experiencing and confirming the issue of BLFs stopping to work also.  I first I thought it was after a certain amount of time, BUT it is after making a change and then applying the change, that the BLFs stay in the state they were in at reload.  I’m on Version 3.0.3-1 & using  pjsip… Rebooting the phones resolves the issue until asterisk is reloaded again, it does not matter what phone manufacturer is being used.  After some research this is a known issue with pjsip.  I don’t want to revert to chan_sip, is there a fix at this time?
    0
    Up
    0
    Down
    Using the CR repo, try updating the asterisk version, and see if on this version the error gets fixed.

    Here’s the link with the instructions to install the CR repo
    https://github.com/VitalPBX/vitalpbx-cr-repo

    Then, you must execute the following command to update the asterisk to version 17.8.0
    yum update asterisk -y

    Please, let me know if the issue gets fixed after updating.

    0
    claudeleg
    Participant
    Up
    0
    Down
    Hi,

    I did install CR repo and update Asterisk and BLF still stop working when I do any change in the system

    0
    Up
    0
    Down
    What kind of hints are you monitoring? What hints do you have configured on your phones?
    0
    claudeleg
    Participant
    Up
    0
    Down
    Hi I’m monitoring others Extension status as BLF

    I have as programmable key all extension from the same Tenant let say extension 100 to 106 plus 2 parking slot 701-702

    Everything is working fine, its blinking when the extension phone is ringing, its become red when others are on the line. But when I did any change over the pbx portal all BLF stay green and wont let you know if other phone are ringin or are busy.

     

    0
    Up
    0
    Down
    Does this happen to the main tenant also? I am just asking this to discard an issue with MT environments.
    0
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.