Lost access to web interface

VitalPBX Community Support General Discussion Lost access to web interface

  • Post
    vitalpbxindia
    Participant

    Suddenly lost access to web interface. reboot does not help. did

    yum clean all  and did yum update -y also.

    systemctl status vpbx-monitor.service httpd.service  – both report as working

    Please help

    if  i login using ssh – i can connect to asterisk cli using – asterisk -rvv

    and sip show peers is responding.

    but i get a error

    [2019-03-20 08:55:11] WARNING[5323]: chan_sip.c:4178 retrans_pkt: Timeout on 1534737418-583927943-346186591 on non-critical invite transaction.

    ————————————————————————————————

    vpbx-monitor.service – VitalPBX Server Monitoring
    Loaded: loaded (/usr/lib/systemd/system/vpbx-monitor.service; enabled; vendor preset: disabled)
    Active: active (running) since Wed 2019-03-20 08:37:19 IST; 13min ago
    Main PID: 5410 (vpbx)
    CGroup: /system.slice/vpbx-monitor.service
    └─5410 /usr/share/ombutel/monitor/vpbx

    Mar 20 08:37:19 mypbx systemd[1]: Started VitalPBX Server Monitoring.
    Mar 20 08:37:20 mypbx vpbx[5410]: Starting VitalPBX Monitor…Server up and running …000
    Mar 20 08:37:20 mypbx vpbx[5410]: Secure Server up and running at host 0.0.0.0 and p…005

    ● httpd.service – The Apache HTTP Server
    Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
    Active: active (running) since Wed 2019-03-20 08:37:18 IST; 13min ago
    Docs: man:httpd(8)
    man:apachectl(8)
    Main PID: 4647 (httpd)
    Status: “Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec”
    CGroup: /system.slice/httpd.service
    ├─4647 /usr/sbin/httpd -DFOREGROUND
    ├─4847 /usr/sbin/httpd -DFOREGROUND
    ├─4848 /usr/sbin/httpd -DFOREGROUND
    ├─4850 /usr/sbin/httpd -DFOREGROUND
    ├─4851 /usr/sbin/httpd -DFOREGROUND
    └─4854 /usr/sbin/httpd -DFOREGROUND

    Mar 20 08:37:17 mypbx systemd[1]: Starting The Apache HTTP Server…
    Mar 20 08:37:18 mypbx systemd[1]: Started The Apache HTTP Server.
    Hint: Some lines were ellipsized, use -l to show in full.

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • Replies
    Up
    0
    Down

    What did you do before lost access?

    Is there any error appearing in the browser?

    Did you check the maridb status?

    0
    vitalpbxindia
    Participant
    Up
    0
    Down

    Hello !

    its a fresh new install. Just configured the trunk and got that working before i started with the extensions

    Actually nothing.. I just clicked on extensions and it took time to respond, in the meanwhile i clicked on dashboard but lost web access completely. – I was creating extensions.

    no response from apache, its like apache died – i cant even telnet on port 80/443 but port 5060 responds

    mariadb looks ok

    ————————————————————–

    systemctl status mariadb.service
    ● mariadb.service – MariaDB database server
    Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
    Active: active (running) since Wed 2019-03-20 09:00:36 IST; 9min ago
    Process: 4744 ExecStartPost=/usr/libexec/mariadb-wait-ready $MAINPID (code=exited, status=0/SUCCESS)
    Process: 4649 ExecStartPre=/usr/libexec/mariadb-prepare-db-dir %n (code=exited, status=0/SUCCESS)
    Main PID: 4743 (mysqld_safe)
    CGroup: /system.slice/mariadb.service
    ├─4743 /bin/sh /usr/bin/mysqld_safe –basedir=/usr
    └─5101 /usr/libexec/mysqld –basedir=/usr –datadir=/var/lib/mysql –plugin-dir=/usr/li…

    0
    Up
    0
    Down

    May be is something regarding to the firewall, you may try to allow the port 80 manually.

    firewall-cmd ---permanent --add-service=http

    firewall-cmd --reload

     

    0
    vitalpbxindia
    Participant
    Up
    0
    Down

    It works now ! 

    Thanks !!! Great !

    0
    Up
    0
    Down

    Check the firewall from the GUI and verify that the port 80 and 443 are allowed.

    If all is ok, save the firewall settings to generate the required rules.

    0
    VoBI
    Participant
    Up
    0
    Down

    Hello,

    Same issue here, however have ran both command and added HTTP ans HTTPS and Reloaded the firewall and still no action. Its a cloud VPS with no rules at all in it i.e completely open.

    I also have this as a brand new installation and could access it last night and then CPU went up to 100% resources. I then ran the integrity checker and that fixed the firewall but now the web interface is broken. Its afresh install and built from the ISO, trying to get a full understanding of this system as we paid for the white labeling.

     

     

    0
    Up
    0
    Down

    Maybe you get banned. If you try to access multiple times with a wrong password or configure a SIP phone with wrong credentials, the system will ban you automatically.

    Where did you install the PBX?

    It appears any errors when trying to access through the browser?

    What are the VPS specifications?

    0
    VoBI
    Participant
    Up
    0
    Down

    I cant ssh in either. it was all working and the VPS is using KVM. after 12 hours of sitting there ready to be configured the next day, the CPU was at 100% I had to restart and again at 100% I than ran vitalpbx integrity-check and it fixed the cpu issue and then the web interface and the ssh is broken, we have not even configured anything yet only created the first user.

    0
    Up
    0
    Down

    If you cannot access through SSH, then, that’s means you have been banned.

    What you can do is try to access with a VPN Proxy.

    Now, Just to clarify, the check-integrity command only changes folders permissions, so, has nothing to do with SSH, HTTP or Firewall.

    0
    kbohannon
    Participant
    Up
    0
    Down

    Same problem here. Thank god for Vypr VPN. Thanks again Mr. M. Another case of VitalPBX working better than expected.

    0
    Up
    0
    Down

    When you installing VitalPBX make sure you adding your public IP address in the firewall whitelist to avoid being banned 

    0
    Up
    0
    Down
    vitalpbx --apply-firewall

    Executing the command above will reset the firewall configuration

    0
Viewing 12 replies - 1 through 12 (of 12 total)

Tagged: 

  • You must be logged in to reply to this topic.