Mailsettings

Up
0
Down
  • Post
    MAX202
    Participant

    Hi to all,

    i had to move from my really old freepbx to new one.

    Now i had some various problems

    one the timezone i get an error

    Error Trace

    # File Function
    1 /usr/share/ombutel/www/index.php:0 appCore->run(…args);
    2 /usr/share/ombutel/www/includes/app/Core.php:0 appCore->_loadModule(…args);
    3 /usr/share/ombutel/www/includes/app/Core.php:0 appCore->loadModuleAction(…args);
    4 /usr/share/ombutel/www/includes/app/Core.php:0 ombutelOmbutelModule->__call(…args);
    5 /usr/share/ombutel/www/includes/OmbutelModule.php:0 modulessystem_miscsystem_miscDB->put(…args);
    6 /usr/share/ombutel/www/modules/system_misc/system_miscDB.php:0 modulessystem_miscsystem_miscDB->put_storage(…args);
    7 /usr/share/ombutel/www/modules/system_misc/system_miscDB.php:0 {closure}(…args);

     

    in the mailsettings i get an red warning on top wtih no text inside

     

    timezone settings not stored, mailseetings are stored but not working

     

    thx max

     

    0
Viewing 15 replies - 1 through 15 (of 17 total)
  • Replies

    What version of VitalPBX are you running? 

    0
    MAX202
    Participant

    VitalPBX 2.4.0-3
    Asterisk 16.6.2-1
    DAHDI 2.11.1-7

    0

    What VPS provider are you using?

    Currently, there are no errors reported on these modules. May you send a screenshot of the modules you are trying to access?, also, I would like to know the steps for reproducing the issue you’re reporting.

    0
    MAX202
    Participant

    its a proxmox server Virtual Environment 6.1-3

    sorry i am to stupid to upload a picture

    change the timesettings to vienna gives the error as shown in my first post

    save the mailsettings from internal to external or something else brings a red block on top for a couple of seconds

     

    0

    Did you go to Admin >> System Settings >> System Misc?

    Then you change the time zone, and finally, when pressing save, the errors appear?

    May you describe what is the info showed on the storage tab?

    0
    MAX202
    Participant

    Yes correct

    Storage shows nothing

    0

    May you try to install the package coreutils

    yum install -y coreutils

    Also, after installing this package, verify the output of the following command:

    df -T
    0
    MAX202
    Participant
    MAX202
    Participant

    In >> System Misc the gui brings on every tab these error

    0

    Ok, the problem is that your virtualizer doesn’t generate regular or common devices name, this avoids that the storage info gets populated on the GUI, and when you try to save, you get that error, because there are no storage notifications to configure.

    This is an output from one of our servers:

    [root@devel www]# df -T
    Filesystem Type 1K-blocks Used Available Use% Mounted on
    devtmpfs devtmpfs 1845404 0 1845404 0% /dev
    tmpfs tmpfs 1857620 0 1857620 0% /dev/shm
    tmpfs tmpfs 1857620 171652 1685968 10% /run
    tmpfs tmpfs 1857620 0 1857620 0% /sys/fs/cgroup
    /dev/mapper/cl-root xfs 112339968 24638684 87701284 22% /
    /dev/sda1 xfs 1038336 254852 783484 25% /boot
    tmpfs tmpfs 371528 0 371528 0% /run/user/0

    On the source code, the Filesystem is filtered by any string starting with “/dev”.In your case, the main file system starts with “rpool”, so, it is not recognized by VitalPBX.

    We will search for a solution, for this issue. I will let you know when this gets fixed.

    0
    MAX202
    Participant

    Cool

    its a zfs pool from proxmox and a lxc container

    then the default centos template and then your script

    its cool thing

     

    can you have a look to my other issue the iax trunk toooooo

     

    thx a lot

    0
    MAX202
    Participant

    I have played around with email settings after update nothing worked

    so i did manually changed the settings in

    /etc/ssmtp/ssmtp.conf

    and

    /etc/ssmtp/revaliases

    mail are now working but are these the right place on vitalpbx

     

    0

    Update to VitalPBX 2.4.0-5, to fix the issue you’ve reported on system misc

    0
    MAX202
    Participant

    i am on 2.4.0-5

     

     

    0
    MAX202
    Participant

    i have now update my other pbx the misc settings are working now but the mailsettings still not work

     

     

    0
Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.