Migrate Ombutel to VitalPBX

VitalPBX Community Support Frequently Asked Questions Migrate Ombutel to VitalPBX

  • Post
Viewing 12 replies - 16 through 27 (of 27 total)
  • Replies
    dsmagghe
    Participant
    Up
    0
    Down

    ombutel version 1.0.30-1

     

    did a yum clean all

    and then I get:

    file /var/lib/asterisk/sounds/en/yeah.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/year.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/years.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/yes-dear.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/yes-dear2.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-are-caller-num.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-are-curr-call-num.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-can-press.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-dialed-wrong-number.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-have-dialed.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-have-reached-a-test-number.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-have-these-options.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-must-first-dial.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-seem-impatient.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-sound-cute.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/you-wish-to-join.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/your-account.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/your-msg-has-been-saved.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/your-msg-is-too-short.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/your-notifications.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/your-req-notification.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/your-temp-greeting.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    file /var/lib/asterisk/sounds/en/zip-code.ulaw from install of asterisk-sounds-extra-en-ulaw-2.0.0-2.noarch conflicts with file from package asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch

    Error Summary
    ————-

    0
    dsmagghe
    Participant
    Up
    0
    Down

    and without the –skip-broken in the script I get to

     

    –> Finished Dependency Resolution
    Error: Package: asterisk-sounds-core-en-gsm-1.4.25-1.noarch (@ombutel)
    Requires: asterisk-sounds-core-en
    Removing: asterisk-sounds-core-en-1.0-3.noarch (@ombutel)
    asterisk-sounds-core-en = 1.0-3
    Obsoleted By: vitalpbx-sounds-2.0.5-4.x86_64 (vitalpbx)
    Not found
    Available: asterisk-sounds-core-en-1.0-1.noarch (ombutel)
    asterisk-sounds-core-en = 1.0-1
    Available: asterisk-sounds-core-en-1.0-2.noarch (ombutel)
    asterisk-sounds-core-en = 1.0-2

    0
    Up
    0
    Down

    The package ”asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch” is not provided by ombutel, so, you have to remove it manually, because have conflicts with VitalPBX packages.

    yum remove asterisk-sounds-extra-en-gb-ulaw-1.4.14-2.noarch
    0
    dsmagghe
    Participant
    Up
    0
    Down

    thanks for the tip, but it doesn’t change anything.

    still getting:

    Error: Package: asterisk-sounds-core-en-gsm-1.4.25-1.noarch (@ombutel)
    Requires: asterisk-sounds-core-en
    Removing: asterisk-sounds-core-en-1.0-3.noarch (@ombutel)
    asterisk-sounds-core-en = 1.0-3
    Obsoleted By: vitalpbx-sounds-2.0.5-4.x86_64 (vitalpbx)
    Not found
    Available: asterisk-sounds-core-en-1.0-1.noarch (ombutel)
    asterisk-sounds-core-en = 1.0-1
    Available: asterisk-sounds-core-en-1.0-2.noarch (ombutel)
    asterisk-sounds-core-en = 1.0-2

     

    0
    Up
    0
    Down

    You have extra package of sounds that are avoiding the installation of VitalPBX. Try to remove all the sounds with the following command:

    yum remove asterisk-sounds*
    0
    dsmagghe
    Participant
    Up
    0
    Down

    hello,

     

    tried that also

    then I get:

    Loading mirror speeds from cached hostfile
    * base: mirror.ams1.nl.leaseweb.net
    * epel: mirror.nl.leaseweb.net
    * extras: mirror.ams1.nl.leaseweb.net
    * updates: mirror.ams1.nl.leaseweb.net
    Package(s) asterisk-sounds-* available, but not installed.
    Error: Nothing to do

    0
    Up
    0
    Down

    What is the output of the following command: 

    ll /etc/yum.repos.d/
    0
    dsmagghe
    Participant
    Up
    0
    Down

    -rw-r–r–. 1 root root 1664 Nov 29 2016 CentOS-Base.repo
    -rw-r–r–. 1 root root 1309 Nov 29 2016 CentOS-CR.repo
    -rw-r–r–. 1 root root 649 Nov 29 2016 CentOS-Debuginfo.repo
    -rw-r–r–. 1 root root 314 Nov 29 2016 CentOS-fasttrack.repo
    -rw-r–r–. 1 root root 630 Nov 29 2016 CentOS-Media.repo
    -rw-r–r–. 1 root root 1331 Nov 29 2016 CentOS-Sources.repo
    -rw-r–r–. 1 root root 2893 Nov 29 2016 CentOS-Vault.repo
    -rw-r–r– 1 root root 957 Dec 27 2016 epel.repo
    -rw-r–r– 1 root root 1056 Dec 27 2016 epel-testing.repo
    -rw-r–r– 1 root root 122 Aug 23 09:17 vitalpbx-migration.repo
    -rw-r–r– 1 root root 122 Aug 23 09:18 vitalpbx-migration.repo.1
    -rw-r–r– 1 root root 122 Aug 23 10:52 vitalpbx-migration.repo.2
    -rw-r–r– 1 root root 122 Aug 23 10:54 vitalpbx-migration.repo.3
    -rw-r–r– 1 root root 122 Aug 23 10:56 vitalpbx-migration.repo.4
    -rw-r–r– 1 root root 122 Aug 23 11:04 vitalpbx-migration.repo.5
    -rw-r–r– 1 root root 122 Aug 23 11:06 vitalpbx-migration.repo.6
    -rw-r–r– 1 root root 122 Aug 23 13:29 vitalpbx-migration.repo.7
    -rw-r–r– 1 root root 454 Aug 21 15:31 vitalpbx.repo
    [root@voip09-dierick ~]#

    0
    Up
    0
    Down

    Execute the following command, then, execute the migration script:

    rm -rf /etc/yum.repos.d/vitalpbx*.repo
    0
    dsmagghe
    Participant
    Up
    0
    Down

    thanx, now the install completes

    but whenever trying to login after reboot

    :

    Fatal error: Uncaught exception ‘Exception’ with message ‘SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘ombutel.ombu_role_permissions’ doesn’t exist With Query: select `allowed` from `ombu_role_permissions` where `role_id` = ? and `permission` = ?’ in /usr/share/ombutel/www/includes/db.php:0 Stack trace: #0 /usr/share/ombutel/www/includes/db.php(0): ombuteldb::__construct() #1 /usr/share/ombutel/www/includes/db.php(0): ombuteldb->__construct() #2 /usr/share/ombutel/www/includes/role.php(0): ombuteldb::query() #3 /usr/share/ombutel/www/themes/vital_pbx/topBar.php(0): ombutelrole->has_permission_for() #4 /usr/share/ombutel/www/themes/vital_pbx/topBar.php(0): themesvital_pbxtopBar->_buildVerticalMenu() #5 /usr/share/ombutel/www/themes/vital_pbx/vital_pbx.php(0): themesvital_pbxtopBar->render() #6 /usr/share/ombutel/www/themes/page.php(0): themesvital_pbxvital_pbx->render() #7 /usr/share/ombutel/www/themes/page.php(0): themespage->_buildBody() #8 /usr/share/ombutel/www/includes/app in /usr/share/ombutel/www/includes/db.php on line 0

     

    so probably part of the update sql script didn’t work out

    0
    dsmagghe
    Participant
    Up
    0
    Down

    ^so tried to manually execute apply_patches:

     

    # ./apply_patches
    Importing 20171123.2.http_server.sql…
    PHP Fatal error: Uncaught exception ‘Exception’ with message ‘ERROR 1062 (23000) at line 35: Duplicate entry ‘HTTPS’ for key ‘name’
    ‘ in /usr/share/ombutel/scripts/apply_patches:0
    Stack trace:
    #0 /usr/share/ombutel/scripts/apply_patches(0): patcher::shellcmd()
    #1 /usr/share/ombutel/scripts/apply_patches(0): patcher->shellcmd()
    #2 /usr/share/ombutel/scripts/apply_patches(0): patcher->import_dbscript()
    #3 /usr/share/ombutel/scripts/apply_patches(0): patcher->apply()
    #4 {main}
    thrown in /usr/share/ombutel/scripts/apply_patches on line 0

    0
    Up
    0
    Down

    Check this post:

    0
Viewing 12 replies - 16 through 27 (of 27 total)
  • You must be logged in to reply to this topic.