MOH issues

  • Post
    tonywhelan
    Participant

    Hi folks

    After several hours of experimenting on a freshly built test installation,I have come to the conclusion that:

    – if you create a MOH class via Settings/PBX Settings/Music on Hold, and upload a suitable music  file(s), then set your Extension/Advanced/MOH Class & Extension/Follow Me/MOH Class to that new MOH class,  calls placed on hold will not hear your music file(s) but will continue to hear the default MOH music supplied by asterisk in folder /var/lib/asterisk/moh.

    So I cannot make my custom MOH music files work.

    Its not a big deal but can you check this sometime and see if you can reproduce the problem?

     

     

    0
Viewing 15 replies - 1 through 15 (of 30 total)
  • Replies
    Up
    0
    Down

    I tried by myself and its working as expected.

    0
    tonywhelan
    Participant
    Up
    0
    Down

    It won’t work for me on my production machine or my freshly-built test machine. I always get the “macroform-cold_day.wav” music from /var/lib/asterisk/moh.  I have tried restarting the PBX (just in case that helped) but it didn’t help.

    I had created a MOH Class called “MOH” and added a sound file to it, and changed both of the test extensions to have MOH Class = “MOH” in the Advanced and Follow Me tabs.

    But the log file shows that moh class “default” was used in the call:

    [2019-02-22 09:08:27] VERBOSE[3360][C-00000004] bridge_basic.c: Channel SIP/201-00000009: Started DTMF attended transfer.
    [2019-02-22 09:08:27] VERBOSE[3358][C-00000004] res_musiconhold.c: Started music on hold, class ‘default’, on channel ‘SIP/206-00000008’

    Am I doing something wrong?

     

     

    0
    tonywhelan
    Participant
    Up
    0
    Down

    Could it be that the WAV files I am using are somehow incompatible with asterisk? In that case would the PBX revert to the default sounds?

     

    0
    tonywhelan
    Participant
    Up
    0
    Down

    Scrap my last suggestion. I uploaded one of the standard asterisk MOH files (manolo_camp-morning_coffee.wav) to my MOH class and removed my other sound files from the class, just in case my own sound files were the problem. But the transfer music is still the default macroform-cold_day.wav. For some reason, my custom MOH class is not being chosen when the warm transfer button (*2) is pressed.

    0
    tonywhelan
    Participant
    Up
    0
    Down

    I could only get MOH to work with my preferred music file by emptying /var/lib/asterisk/moh and copying my preferred music file into that folder.

    Just to be clear, I am using VitalPBX 2.1.1-1 and this happens on two freshly -built machines.

     

    0
    Up
    0
    Down

    Very strange.

    This happens also in Internal environments? 

    0
    tonywhelan
    Participant
    Up
    0
    Down

    Yes. I tested extn-to-extn calls, as well as incoming calls via inbound route.

    0
    tonywhelan
    Participant
    Up
    0
    Down

    Just for the record, I just did a build of version 2.2.1-1 (RC) and had exactly the same problem.  The system only plays the default moh, not the new moh class I defined in the VPBX GUI.

     

    0
    Up
    0
    Down

    May you share the call flow? Where did you set the moh?

    0
    tonywhelan
    Participant
    Up
    0
    Down

    This is how I set it up:

    Settings/PBX Settings/Music on Hold. Create MOH Class called “MOH”

    Settings/PBX Settings/Music on Hold/MOH. Upload  the music file to this class.

    For each extension, set Advanced/MOH Class and Follow Me/MOH Class to “MOH”

    Trunks and Inbound Routes also have their MOH Class set to “MOH”

    Extract from log is attached for a call from x201 to x210, where the recipient presses *2 for a warm transfer, and the sender (x201) receives music on hold. As you can see from the log, the moh class is “default”

     

    0
    tonywhelan
    Participant
    Up
    0
    Down

    I should just add that the log extract attached above was for a call made on my live/production system (v2.1.1-1), but the test system (cv2.2.1-1rc)  shows the same behaviour.

     

     

    0
    tonywhelan
    Participant
    Up
    0
    Down

    I have come to the conclusion that the module for creating an MOH Class in VitalPBX is only being used by the Settings/Technology Settings/Dial Profiles module, it is not being used by the Extensions/Extension/Advanced/MOH Class module.

    This seems to be to be a bug?

    0
    Up
    0
    Down

    The MoH on dial profiles if to define if the caller will listen to the ring tone or an MoH class before the called answer, in the extensions, under the advanced tab the MoH class is for when called put on hold to the caller.

    What I didn’t try yet is the transfer option, to see what MoH class is played

    0
    Up
    0
    Down

    I made some research about this topic and made some test with the transfer option, and effectively, the play moh during a transfer is the asterisk default moh, a workaround is to add the parameter  (In the tab  “custom” on SIP Settings dialog) “mohinterpret” follows by the desired music on hold class as shown in the attached picture.

    To list the available moh classes, you may execute the following command in the Linux console:

    asterisk -rx”moh show classes”

     

    0
    tonywhelan
    Participant
    Up
    0
    Down

    Thank you for this information. I have tested the suggested Custom field workaround and it works nicely.

    Will the original problem be treated as a bug and fixed sometime?

     

    0
Viewing 15 replies - 1 through 15 (of 30 total)

Tagged: 

  • You must be logged in to reply to this topic.