Multi Tenant FollowMe Hint

VitalPBX Community Support General Discussion Multi Tenant FollowMe Hint

  • Post
    PitzKey
    Participant
    US

    Hello,

    I am having trouble getting the FollowMe hint to work under multi tenant. Does anyone have it working?

    To be clear it toggles FollowMe just fine, but the BLF does not change.

     

    After looking at the logs I see the below.

    [root@pbx1 ombutel]# asterisk -rx"core show hints" | grep FWM_201
    FWM_201@T8_extensi: Custom:T8_FWM_201 State:Idle Presence:not_set Watchers 1

    So it seems like the state does not change, but the DB seems to be updated as you can see here:

    [root@pbx1 ombutel]# asterisk -rx"database show" | grep FWM_201
    /CustomDevstate/FWM_201 : BUSY

    So I went to a system that is not a multi tenant, and it appears to be working there just fine, and as you can see the sate is set to Busy:

    [root@core ~]# asterisk -rx"core show hints" | grep FWM_550
    FWM_550@extension-h: Custom:FWM_550 State:Busy Presence:not_set Watchers 1
    [root@core ~]# asterisk -rx"database show" | grep FWM_550
    /CustomDevstate/FWM_6406 : BUSY

    I tried looking at the logs to compare, it seems to me like the problem is within the /usr/share/ombutel/scripts/synchronizer script.

    Not multi tenant system:

    Goto (cos-all-post,*67,1)
    -- Executing [*67@cos-all-post:1] NoOp("SIP/550-000000b9", "Follow Me - Toggle") in new stack
    -- Executing [*67@cos-all-post:2] Gosub("SIP/550-000000b9", "sub-followme-state,s,1") in new stack
    -- Executing [s@sub-followme-state:1] NoOp("SIP/550-000000b9", "SUB: FOLLOWME ENABLED/DISABLED") in new stack
    -- Executing [s@sub-followme-state:2] Answer("SIP/550-000000b9", "") in new stack
    -- Executing [s@sub-followme-state:3] GotoIf("SIP/550-000000b9", "0?disable_fwm") in new stack
    -- Executing [s@sub-followme-state:4] Set("SIP/550-000000b9", "DB(55d329b7d866a982/diversions/550/FWM/enable)=yes") in new stack
    -- Executing [s@sub-followme-state:5] Set("SIP/550-000000b9", "DB(55d329b7d866a982/diversions/550/has_enable_diversions)=yes") in new stack
    -- Executing [s@sub-followme-state:6] Set("SIP/550-000000b9", "DEVICE_STATE(Custom:FWM_550)=BUSY") in new stack
    -- Executing [s@sub-followme-state:7] System("SIP/550-000000b9", "/usr/share/ombutel/scripts/synchronizer "enable-FWM" "55d329b7d866a982" "550"") in new stack
    == Extension Changed FWM_550[extension-hints] new state Busy for Notify User 550
    -- Executing [s@sub-followme-state:8] Playback("SIP/550-000000b9", "vpbx/vital-follow-me&activated") in new stack
    -- <SIP/550-000000b9> Playing 'vpbx/vital-follow-me.slin' (language 'en')
    -- <SIP/550-000000b9> Playing 'activated.ulaw' (language 'en')
    -- Executing [s@sub-followme-state:9] Hangup("SIP/550-000000b9", "") in new stack

     

    Multi tenant system:

    Goto (T8_cos-all-post,*67,1)
    -- Executing [*67@T8_cos-all-post:1] NoOp("SIP/T8_201-00004424", "Follow Me - Toggle") in new stack
    -- Executing [*67@T8_cos-all-post:2] Gosub("SIP/T8_201-00004424", "sub-followme-state,s,1") in new stack
    -- Executing [s@sub-followme-state:1] NoOp("SIP/T8_201-00004424", "SUB: FOLLOWME ENABLED/DISABLED") in new stack
    -- Executing [s@sub-followme-state:2] Answer("SIP/T8_201-00004424", "") in new stack
    -- Executing [s@sub-followme-state:3] GotoIf("SIP/T8_201-00004424", "0?disable_fwm") in new stack
    -- Executing [s@sub-followme-state:4] Set("SIP/T8_201-00004424", "DB(96528061f5cffe16/diversions/201/FWM/enable)=yes") in new stack
    -- Executing [s@sub-followme-state:5] Set("SIP/T8_201-00004424", "DB(96528061f5cffe16/diversions/201/has_enable_diversions)=yes") in new stack
    -- Executing [s@sub-followme-state:6] Set("SIP/T8_201-00004424", "DEVICE_STATE(Custom:FWM_201)=BUSY") in new stack
    -- Executing [s@sub-followme-state:7] System("SIP/T8_201-00004424", "/usr/share/ombutel/scripts/synchronizer "enable-FWM" "96528061f5cffe16" "201"") in new stack
    -- Executing [s@sub-followme-state:8] Playback("SIP/T8_201-00004424", "vpbx/vital-follow-me&activated") in new stack
    -- <SIP/T8_201-00004424> Playing 'vpbx/vital-follow-me.slin' (language 'en')
    -- <SIP/T8_201-00004424> Playing 'activated.ulaw' (language 'en')
    -- Executing [s@sub-followme-state:9] Hangup("SIP/T8_201-00004424", "") in new stack

    As you can see on the not multi tenant system, the log says right after that script

    Extension Changed FWM_550[extension-hints] new state Busy for Notify User 550

     

    Let me know if you need any further info.

     

    Thanks

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • Replies
    Up
    0
    Down

    We will check it, thanks for reporting it

    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Hi,

    I know it’s not been only a week, but we need this quite urgent. Were you able to reproduce this issue?

    Thanks

    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Is anyone able to reproduce this issue? So we know if this is something wrong on our PBX, or a general VitalPBX issue.
    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    This has been fixed in the latest update. Thank you VitalPBX Team!

    Edit; How can I mark this topic as solved?

    • This reply was modified 2 months, 3 weeks ago by PitzKey.
    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Multi Tenant FollowMe Hint’ is closed to new replies.