Need help setting up Inbound calling

VitalPBX Community Support General Discussion Need help setting up Inbound calling

  • Post
    JohannS
    Participant
    Up
    1
    Down
    Hi there

    I need a little help getting inbound going, I’m clearly missing something. I can phone out no problem.

    I only have 1 trunk set up, and I’ve set up a default route to route all calls to my extension, which is in the only Tenant on the server.

    I get this when I phone the DID from my cellphone:

    [2021-03-14 07:01:09] NOTICE[26120]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘INVITE’ from ‘”+27635461865″ <sip:27635461865@154.118.245.222>’ failed for ‘154.118.245.222:5060’ (callid: 3f783085-ff25-1239-cba8-0050569697c5) – No matching endpoint found
    [2021-03-14 07:01:09] NOTICE[1268]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘INVITE’ from ‘”+27635461865″ <sip:27635461865@154.118.245.222>’ failed for ‘154.118.245.222:5060’ (callid: 3f783085-ff25-1239-cba8-0050569697c5) – No matching endpoint found
    [2021-03-14 07:01:09] NOTICE[1268]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘INVITE’ from ‘”+27635461865″ <sip:27635461865@154.118.245.222>’ failed for ‘154.118.245.222:5060’ (callid: 3f783085-ff25-1239-cba8-0050569697c5) – Failed to authenticate

    154.118.245.222 is the upstream SIP provider.

    I’m clearly missing a step or config somewhere.

    Please help

    JohannS

    0
Viewing 3 replies - 1 through 3 (of 3 total)
  • Replies
    JohannS
    Participant
    Up
    0
    Down
    Just some more information.

    Internal calling works 100%. I’m hosted on-premise in my own DC where clients will connect to.

    I’m attaching output from pjsip show endpoints.

    0024* is the custom prefix I have for the tenant I’m testing with.

     

     

     

     

    • This reply was modified 4 months, 2 weeks ago by JohannS.
    Attachments:
    You must be logged in to view attached files.
    0
    Rodrigo Cuadra
    Keymaster
    US
    Up
    -1
    Down
    In the inbound route you need to setting: +27635461865 (with the “+”).
    0
    Up
    0
    Down
    On your trunk type the inbound IP addresses of your provider in the “match” field.
    0
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.