No data on the dashboard (2.2.1-1rc)

VitalPBX Community Support General Discussion No data on the dashboard (2.2.1-1rc)

  • Post
    powersurge
    Participant

    I am running into this issue with version 2.2.1-1rc. Ports 3000 and 3005 are both opened in Admin > Security > Firewall and I cleared my browser cache. The dashboard only works over http and not over https. Https only shows all zeros on the dashboard.

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • Replies
    Up
    0
    Down

    Where do you have installed the PBX? Locally or Cloud?

    0
    powersurge
    Participant
    Up
    0
    Down

    It’s installed in the cloud. I’m using Vultr.

    0
    weconex
    Participant
    Up
    0
    Down

    Check your firewall on vultr…

    0
    Up
    0
    Down

    Are you using the firewall provided by vultr?

    0
    powersurge
    Participant
    Up
    0
    Down

    I checked the settings and “no firewall” is selected.

    0
    Up
    0
    Down

    Are you using an specific type of certificate? Did you generate a new certificate?

    0
    powersurge
    Participant
    Up
    0
    Down

    I’m just using a Let’s Encrypt certificate.

    0
    Up
    0
    Down

    And the web gui is working? Only the dashboard is failing over https?

    0
    powersurge
    Participant
    Up
    0
    Down

    Everything else seems to be working ok… what I have noticed is that even though I set up a Let’s Encrypt certificate, it is not being used. I am still getting the Insecure Certificate notification.

    0
    powersurge
    Participant
    Up
    0
    Down

    Ok I feel stupid! Its working now… I just had to select my Let’s Encrypt certificate in the HTTP Server section. Thank you for your assistance.

    0
    Up
    0
    Down

    Check the expiration date of let’s encrypt certificate.

    0
    powersurge
    Participant
    Up
    0
    Down

    Expires June 6th, 2019. It’s working now. The problem was that I didn’t have the Let’s Encrypt certificate selected in Admin > System Settings > HTTP Server. Thank you for all of your help! I really appreciate it.

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.