No ring tone played to caller

VitalPBX Community Support General Discussion No ring tone played to caller

Up
0
Down
  • Post
    tonywhelan
    Participant

    Moved my PBX solid-state-drive to another piece of hardware today to allow me to service a faulty fan. Everything seems to work except:

    – External callers no longer receiving any ring tone.

    – Internal callers receive MOH instead of ring tone.

    Log shows this:

    [2019-02-17 10:43:11] VERBOSE[6287] loader.c: Reloading module ‘app_voicemail.so’ (Comedian Mail (Voicemail System))
    [2019-02-17 10:43:11] WARNING[6287] file.c: ignoring unknown format ‘wav49,wav,gsm’
    [2019-02-17 10:43:11] WARNING[6287] file.c: no known formats found in format list (wav49,wav,gsm)
    [2019-02-17 10:43:11] ERROR[6287] app_voicemail.c: Error processing format string, defaulting to format ‘wav’
    [2019-02-17 10:43:11] VERBOSE[6287] loader.c: Reloading module ‘app_amd.so’ (Answering Machine Detection Application)

    Any suggestions about what is causing this?

    cheers

    Tony

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • Replies
    tonywhelan
    Participant

    Correction to above post.

    Both external and internal callers receive MOH rather than ring tone.

    (I had initially tested the external using a mobile/cell phone which had volume turned down low )

    0

    To configure the “ringback” tone, instead of MoH, go to the extensions module, and, under the Advanced tab, go to “Music on Hold Class” field, and select the option “None (ringback)”.

    Check the picture attached

    0
    tonywhelan
    Participant

    Thank you mrivera

    I had already tried that solution, but it made no difference. Just checked it again, extensions are set to “None (ringback) but they are still getting MOH.

    I suspect my installation has become corrupted.  I am doing a fresh build on a test machine so that I can replace the existing disk drive with the fresh build.

     

    0

    Check the dial profiles (Settings / Technology Settings / Dial Profiles), if the MoH field is set to none.

    0
    tonywhelan
    Participant

    Well I just built a fresh VitalPBX installation on a 16GB USB stick, configured everything same as my production machine, all working except I am still getting MOH instead of ring tone.

    Settings / Technology Settings / Dial Profiles is set to “None (Ringback)” and every extension is set to “None (Ringback)”, as is every Inbound route and every Ttrunk.

    When I call internally (extn to extn) I get MOH not ring tone.

    I have four trunks set up each  with a DID/Inbound Route. Two  DIDs are with one provider, two are with another provider.

    When I use a cell phone to call the DIDs for each of those trunks, two of them (different providers)  eturn MOH to the caller, one returns ring tone, and one is silent.

    I am unable to understand how or why this is happening. Is there some setting I have missed?

    regards

    Tony

     

    0
    tonywhelan
    Participant

    For info, the attached is a log extract calling extn 201 from extn 209.

     

     

    0
    tonywhelan
    Participant

    Just so you know, I am using the en_AU Australian sound set, though I can’t imagine that makes any difference.

    0

    According to the shared log, you have enabled the music on hold class in the dial profiles of your extension:

    Set(DIAL_OPTIONS=trm(moh2)b(set_dial^1)B(moh^1)):Set(DIAL_OPTIONS=trm(moh2)b(set_dial^1))") in new stack

     

    This is a log of an internal call on my test environment:

    Set(DIAL_OPTIONS=tTrb(set_dial^1)B(moh^1)):Set(DIAL_OPTIONS=tTrb(set_dial^1))") in new stack

    As you see, in my test environment I have set the MoH class value to None(Ringback), and not MoH is delivered to the caller, instead a ring tone is played. 

    I recommend the following, after configure your PBX with the desired options, try executing this command on the Linux console:

    php /usr/share/ombutel/scripts/dump_asterisk_conf

     

    0
    tonywhelan
    Participant

    Hi Jose

    I know it looks like I had it set to MOH, but it isn’t set to that in the GUI, that’s why I sent the log extract.

    In the GUI every extension’s Advanced tab is set to MOH= “None(ringback)”

    But I have just tried the suggested “dump_asterisk_conf” command and it has restored the ringback tone to normal. Thank you!! 

    Does running that command wipe any of my other settings?

    I am still puzzled about why this problem happened, as this was a fresh clean build of VitalPBX. I kept a written record of every setting I configured, and none of the settings had MOH enabled. 

    There are three scripts added to the Task Manager. One of the scripts is a trunk-check that runs every 5 minutes, I can’t see why that would cause a problem though as it had been in use on the previous machine for months.

    For now it looks to be back to normal, so thank you for your great support.

    Tony

     

     

    0

    You’re welcome.

    The command that I provided you creates all the settings (Files, SQLite Info) from scratch, if you have any similar issue, you may execute this command to keep all your settings clean

    0
    tonywhelan
    Participant

    I’ll keep a note of that command just in case I ever need it again, though I hope it won’t be necessary .

    I will close this topic. Enjoy your day, I’m going back to bed (2.30am).

    0

    Here is 9:48 A.M, so, enjoy your night!!

    0
Viewing 12 replies - 1 through 12 (of 12 total)

Tagged: 

  • You must be logged in to reply to this topic.