no way audio on any call forwarding

VitalPBX Community Support General Discussion no way audio on any call forwarding

Up
0
Down
  • Post
    mo10
    Participant

    I have a problem when forwarding any call. CFI or Ring Group (to external) or Follow Me, all have no way audio when “forwarding” a call.

    Regular inbound or outbound calls are working without a problem.

    Could you please, help? This is what the provider said:

    “There is nothing to hear because there are no RTP-pakets coming from VitalPBX. Only sip-signals are visible on forwarding. The VitalPBX is only signaling private ip-addresses that can’t be used by the provider. SDP same thing: only private ips. VitalPBX should send RTP-pakets first, which it does not.
    Provider is sending a 200OK. At this point the VitalPBX needs to send the RTP-pakets. On forwarding the RTP-stream must be initiated by the VitalPBX which it does not.”

     

    Thank you!

    0
Viewing 2 replies - 1 through 2 (of 2 total)
  • Replies
    phil
    Participant

    I had this problem. I added the following lines to my trunk config under outgoing

    insecure=port,invite
    fromdomain=mypbx.mydomain.com
    qualify=yes
    sendrpid=yes
    keepalive=yes
    progressinband=yes
    nat=yes
    localnet=192.168.1.0/24

    You need to change localnet to your own vitalpbx subnet, you need to change fromdomain to the external wan static ip (check with ipchicken), or setup dynamic dns if you dont have a static.

    Then unblock your RTP range in your firewall. This range is found in your vitalpbxx RTP settings

    Now when the RTP changes after the call forward, it wont get cut off – this also seems to fix another weird issue of getting cutoff after 15mins on hold

    YMMV

     

    0
    mo10
    Participant

    Thanks for your input.

    Tried all of you hints but did not work.

    Wordaround: if I i use a Night Mode on inbound-routes and then Call Forward the no way audio is gone.
    Why? Because there is some kind of auto-answer?

    0
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.