One way audio issue

VitalPBX Community Support General Discussion One way audio issue

  • Post
    acoolov
    Participant

    We’ve spent 3 days testing VitalPBX and so far, the biggest issue for us is one way audio, primarily on all the soft phones that we tried, and on one cisco phone. Just wanted to report the issue details here so that it could be useful for others when it gets resolved. To VitalPBX develovers (could you guys please try to replecate our install? Vultr only charges per minute, so there is literally almost no expense in deploying and testing it on Vultr). 

    Our setup:

    Installed a new VitalPBX on Vultr cloud server (with a public IP)

    Setup trunks with flowroute – worked but took a while to figure out how to enter the information correctly (coming from FreePBX world).

    Inbound outbound routes – works as expected so far.

    Setting up extensions and logging the phones in – worked with Sangoma S500 and Polycom VVX400 with audio working both ways. 

    One way audio with these phones on any type of network connection – Cisco SPA508G, Zoiper softphone (mobile and pc), Bria softphone (mobile and pc). Tried playing around with codecs, but it looks like it’s not a codec issue.

    No matter what we did, there is always one way audio on those phones, and somehow works on Sangoma and Polycom. 

    Searched through the online manual but some modules there are pretty much the same information what’s already in the VitalPBX hints.

    We though it was because we changed around some sip and pjsip port numbers to our custom port numbers, but when we tried installing a brand new deployment in a new Vultr server, we went straight to extensions, without configuring anything else. Created two extensions and tried calling each other but for some reason had problems with audio even on Sangoma and Polycom. Also had problems with phone registrations for some odd reason. But the main thing is one way audio right out of the box. If the creators could replicate this on a Vultr server that would be great!

    We also tried entering a public IP in the pjsip settings but that setting won’t save in the VitalPBX gui. Maybe it’s a bug. I wonder if that would fix the issue if it was able to save the ip address.

    0
Viewing 6 replies - 1 through 6 (of 6 total)
  • Replies
    Up
    0
    Down

    Which port are you using for SIP and PJSIP?

    0
    acoolov
    Participant
    Up
    -1
    Down

    It behaves the same way even with the default ports 5060 for sip and 5062 for pjsip. And we always use pjsip extensions.

    0
    Up
    0
    Down

    Ok, thanks for reporting it, we will make our own lab to give you a solid solution.

    0
    acoolov
    Participant
    Up
    -1
    Down

    Thanks! Looking forward to hearing from you!

    0
    Up
    0
    Down

    With the SIP protocol we didn’t make any change, because it worked as expected, unlike PJSIP, that was need to change a specific parameter to work.

    The PJSIP parameter is named “RTP Symmetric (rtp_symmetric)”, this parameter allows you to configure the PJSIP protocol to send the RTP packages back to the same address/port were was received it from.

    You can change this parameter in the Technology Profiles module(Settings >> Technology Settings >> Profiles). You must set this parameter to Yes.

    About PJSIP Settings module, we have determinate that there are some issues that we must to fix, however, this issues doesn’t affect the PJSIP calls, except if is behind nat, due there are some settings that is no possible to save trought this module.

    0
    acoolov
    Participant
    Up
    -1
    Down

    I just tested with RTP symmetric and it works! Thanks! Looking forward to the following versions.

    0
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.