Outbound CID not displaying

VitalPBX Community Support General Discussion Outbound CID not displaying

  • Post
    taylor
    Participant

    Hi Guys,

    I seem to be having an issue with getting my outbound CID to display I check the “overwrite CID” option to yes and then enter my number but calls still appear as anonymous or unknown. Am I missing something? My trunks are registered through Vitelity and I have several other PBX systems with this function working and able to set custom even fictitious CIDs via the PBX. Any insight or help is appreciated!

     

     

    Thanks,

    Taylor

     

       

    0
Viewing 4 replies - 16 through 19 (of 19 total)
  • Replies
    toerlemans
    Participant
    Up
    0
    Down
    Posted by: mrivera

    Ask to your provider if needs an special header to send the CID

    I have been in touch with our provider and after changing some more things on their side it started to work.

    Ofcourse I am satisfied it’s finally working but I also would like to apologize for the wasted time since it ended up being a provider issue after all.

    0
    ICTALL
    Participant
    Up
    0
    Down

    By default, it seems VitalPBX sends the “extension” as callerID.

    I have tested VitalPBX with 2 providers: CheapConnect.net and VoipPlanet.nl.
    Cheapconnect will show the CID you have set in the CheapConnect portal.

    VoipPlanet (and perhaps fieber.nl) will show NO callerid if the CID doesn’t match the CID linked with the trunk.
    With VoipPlanet I had to rewrite the CID using the international telephone number notation:

    31NNXXXXXXX    *eg.   31851234567    for Dutch number 085-1234567

    I didn’t have to, but you may have to the put the “+” in front of the country number.

    The nice thing about VoipPlanet I believe, is they could link several CID to your trunk, so you could choose your outbound CID if you e.g. are using one PBX for several company locations.

    0
    Up
    0
    Down

    It actually sends the external CID value of the extension that usually is the same extension number when is not configured with a different value.

    If you want to learn more about VitalPBX environment, tips, and tricks, you may attend our online training course: https://vitalpbx.org/en/vitalpbx-online-training-course/

    0
    Falombard25
    Participant
    Up
    0
    Down

    Hi @toerlemans @taylor

    -This issue can be mitigated by leaving empty “From users” and “From domain” as @mrivera and myself pointed out.

    On the Trunk, the parameter “From”  you don’t need to add anything. That option will replace the SIP username renaming the one you have in your phone and whatnot. I have seen it in many asterisk application including CUCM.

    By default, the system sends the CID you have configured on your extension.
    Also, you can control your outbounds via outbound rules or trunking rules besides using the extension as well. It all depends where do you want to control your outbound based on rules.

    Now, Caller-ID are not controlled by VoIP providers. Providers can only control Caller-ID lookups using CNAM to lookup names callers. 

    Once you have registered your system via the “Register String” you will be sending outgoing calls. You can even spoof numbers that aren’t real, so I highly doubt after tweaking a bit on the provider you could’ve able to fix it. It seems to be something in your system THAT is OR not checked. 

    But glad you figured something out at the end of the day.

    0
Viewing 4 replies - 16 through 19 (of 19 total)
  • You must be logged in to reply to this topic.