Outgoing CID – Not Displayed

VitalPBX Community Support General Discussion Outgoing CID – Not Displayed

Up
0
Down
  • Post
    Ryado
    Participant

    Hello All,

    I am currently testing outbound calls with the Vital PBX through one of our VoIP provider. I am able to successfully make an outbound call from a PBX extension to a network subscriber, however the CID of the extension is showing up as Unknown.

    “Overwrite CID” is disabled. “Get CID From” is set to Default but also tried the “Contact” and “From” options.

    I have asked the provider for assistance and they are expecting the “P-Asserted-Identity” field in the Invite. It is not being sent currently.

    In addition, they would like “user=phone” in the Request-URI and Header

    I would appreciate you guidance in helping me set/enable those two fields.

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • Replies

    You may try the following:

    • Go to the devices profiles (Settings >> Technology Settings >> Profiles), select your SIP profile (By default is “Default SIP Profile”), and check the value of the field “Send Remote Party ID“, must be set to “Use PAI“.
    • In your trunk configurations, go to the Advanced tab, and set on custom headers section the following info:
      • Header: P-Asserted-Identity
      • Value: <sip:{CIDNUM}@{HOST}>
      • Enabled: Yes
    • In your trunk, you may set the parameter “usereqphone=yes“, in order to send “;user=phone”  on URI

     

    0
    Ryado
    Participant

    Thank you for your detailed responses. I have managed to update the Default SIP Profile as requested.

    For the Trunk Configurations:

    • Would you be able to check over the settings I have placed for PAI
      • In Advanced > Custom Settings

     

    • I am unable to find the parameter “usereqphone=yes” to set to yes.

    The following is the versions I am running:

    • VitalPBX 2.1.1-1
    • Asterisk 13.23.1-1

    Can you confirm if the parameter is available for that version.  If not, is there a workaround in the meantime? However, I am getting the “;user=phone”  on URI now as I have manually updated the sip__50-1-trunks.conf file.

    Currently we are still unable to get the PAI. I suspect something is lacking in my configuration from the above.

    0

    Sorry dude, you must update to the latest version of VitalPBX in order to send custom headers.

    0
    Ryado
    Participant

    Thank you very much for the feedback. I will make the update and inform you on the outcome.

    I really appreciate your assistance.

    0

    You’re welcome

    0
    Ryado
    Participant

    Hello again,

    Is there a simple way to rollback to the current software version in the event of any issues with the new version?

    In addition, can yo confirm the following is the update procedure:

    • Clean cache: yum clean all
    • Update to Latest version: yum update vitalpbx

     

    0

    No, until now is not possible to do a rollback.

    About the procedure of updating VitalPBX, the answer is yes, that’s the procedure.

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.