Outgoing External CID not showing as set for extension

VitalPBX Community Support General Discussion Outgoing External CID not showing as set for extension

  • Post
    JanBergner91
    Participant

    I have the following Problem:

    If i take a call outside the PBX: internal -> external : the number i set in extension config is not shown. instead the provider fallback number is provided. The provider is Sipgate. The support tells me that there is no SIP-Header like (P-Preferred-Identity: sip:492111234567@sipconnect.sipgate.de) provided. I have not found any solution in the config.

     

    Has anybody an idea?

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • Replies
    Up
    0
    Down

    That’s a requirement specifically for that VoIP Provider.  What you can do is modify the “sub-construct-cid” context, located at /etc/asterisk/ombutel/extensions__20-baseplan.conf, however, this file is overwritten each time the Software is updated to a new version.

    You should modify the s-external extension on “sub-construct-cid“, and add the required headers.

    0
    JanBergner91
    Participant
    Up
    0
    Down

    Hello mrivera,

    i have now contacted some other SIP-Providers (5) and 4 of them require exactly this Header (P-Preferred-Identity). I tested this settings in 3CX and it worked perfectly. But i am still on VitalPBX-Way. Is there any possibility to add this as Feature?

    0
    Up
    0
    Down

    We will try to add this feature for the next version. Thanks for using VitalPBX

    0
    Up
    0
    Down

    Now is possible to define custom SIP / PJSIP headers per trunk on Version 2.3.0

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.