Outgoing External CID not showing as set for extension.

VitalPBX Community Support General Discussion Outgoing External CID not showing as set for extension.

  • Post
    Ofloo
    Participant

    External CID not showing, on my cell phone. The default is. How can I force a specific External CID ?

    0
Viewing 11 replies - 1 through 11 (of 11 total)
  • Replies
    Up
    0
    Down

    If the trunk is marked to overwrite the CID, then, trunks CID will take precedence over any CID.

    Another thing you must to take into account, if is you provider allows you to send custom CIDs.

    0
    Ofloo
    Participant
    Up
    0
    Down

    No CID overwrite isn’t active tried with and without, doesn’t matter, .. this issue is been going on for a while.

    I used to run elastix and there it always worked fine but for this trunk I wasn’t able to set it right for some reason, not on ombutel nor on vitalpbx. I’m not sure why that is though.

    I’m sure its some configuration, that needs to be done but can’t put my finger on what it is.

    *not sure but I believe it did work in one of the first releases of ombutel, .. have been using it since it released version 1 or something, I did make a post about it, but  no one ever really to responded to it.

    It’s a betamax sip provider, .. the numbers have been verified, .. I can set them statically and if I would have one number it wouldn’t matter, .. but that’s not the case.

    0
    Up
    0
    Down

    May you explain the call Flow?

    Extension => Call to External Number

    Or

    Extension => Is being called by external number => Call is forwarded to an External Number

    0
    Ofloo
    Participant
    Up
    0
    Down

    Extension => Call to External Number

    0
    Up
    0
    Down

    Ask to your VoIP provider if they are overwriting the Caller ID?

    0
    Ofloo
    Participant
    Up
    0
    Down

    Yeah i thought that too but then I reran the elastix vm and it just worked. So if if elastix was able to overwrite/set the Caller ID why can’t vitalpbx.

    0
    TrustedbyU
    Participant
    Up
    0
    Down

    Is the Trunk configuration identical in both? I had similar issues when moving from Elastix to Ombutel. It turned out that there was a slight difference in the 2  trunks configuration. I can’t remember what the issue was it was either the setting of from-user (which wasn’t required) or the register string was slightly different.

    I am pretty sure in my case my provider was sending on the From-User instead of the set caller ID. Unsetting From-user then used my caller id……

    0
    Ofloo
    Participant
    Up
    0
    Down

    I’ll look into it.

    0
    Ofloo
    Participant
    Up
    0
    Down

    I finally figured out what was wrong, ..

    and this seems to be the case for all betamax voip providers, ..

    don’t set the fromuser to anything just leave it empty, and caller id works ..!?

    0
    TrustedbyU
    Participant
    Up
    0
    Down
    Posted by: Ofloo

    I finally figured out what was wrong, ..

    and this seems to be the case for all betamax voip providers, ..

    don’t set the fromuser to anything just leave it empty, and caller id works ..!?

    Yeah this is pretty normal Behaviour. Glad you got it sorted in the end 🙂

    0
    Ofloo
    Participant
    Up
    0
    Down

    Just thought i’d post so other people can take advantage of it. I’m glad I found it to ? 

    0
Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.