Paging Auto Answer on Polycom Phones

VitalPBX Community Support General Discussion Paging Auto Answer on Polycom Phones

  • Post
    rnbruce
    Participant
    Up
    0
    Down

    I have a setup with approximately 90 polycom phones.  When paging to the phones, they will ring one time then answer.  They do a lot of paging so the ring is very undesirable.  They also end up with a lot of voicemails from extensions that are paging.   I am trying to remove the ring before the answer.  Polycom has a setting for auto answer but it is for all calls so it will not work in this case.   I see the system is sending out the Alert-info of ring-answer.  I am hoping there is a way to change so it will just send the Alert-info of answer.  Looking for any information someone might have to help with this issue.

     

    Thanks

    0
Viewing 6 replies - 1 through 6 (of 6 total)
  • Replies
    PitzKey
    Participant
    US
    Up
    0
    Down
    Posted by: @rnbruce

    I am hoping there is a way to change so it will just send the Alert-info of answer.

    Instead of?

    0
    rnbruce
    Participant
    Up
    0
    Down

    Instead of of ring-answer

    0
    rnbruce
    Participant
    Up
    0
    Down

    They need the intercom calls to answer without ringing.    

    0
    rnbruce
    Participant
    Up
    0
    Down

    For anyone who may be interested, here’s the outcome.  Vitalpbx was able to direct me to the correct config file extension_20-baseplan.conf to modify.  This is the settings I ended up with in the sub-auto-answer

    [sub-auto-answer]
    exten => s,1,NoOp(Set up ${CHANNEL(channeltype)} Headers)
    same => n,GotoIf($[“${CHANNEL(channeltype)}”=”SIP”]?set-sip)
    same => n,NoOP(Add PJSIP Headers)
    same => n,Set(PJSIP_HEADER(add,Call-Info)=<uri>;answer-after=0)
    same => n,Set(PJSIP_HEADER(add,Alert-Info)=Answer)
    same => n,Set(PJSIP_HEADER(add,intercom)=true)
    same => n,Set(PJSIP_HEADER(add,Call-Info)=<sip:broadworks.net>;answer)
    same => n,Set(PJSIP_HEADER(add,Alert-Info)=Intercom)
    same => n,Set(PJSIP_HEADER(add,Alert-Info)=info=Auto Answer)
    same => n,Set(PJSIP_HEADER(add,Alert-Info)=answer)
    same => n(set-sip),NoOP(Add SIP Headers)
    same => n,SIPAddHeader(Call-Info: <uri>;answer)
    same => n,SIPAddHeader(Alert-Info: Answer)
    same => n,SIPAddHeader(intercom=true)
    same => n,SIPAddHeader(Call-Info: <sip:broadworks.net>;answer
    )
    same => n,SIPAddHeader(Alert-Info: Intercom)
    same => n,SIPAddHeader(Alert-Info: info=Auto Answer)
    same => n,SIPAddHeader(Alert-Info: answer)
    same => n,Return()

     

    I added a config file named “macaddress-web.cfg” in the provision folder that had these settings.

    voIpProt.SIP.alertInfo voIpProt.SIP.alertInfo.1.class=”Auto Answer”
    voIpProt.SIP.alertInfo.1.value=”Auto Answer”
    voIpProt.SIP.alertInfo.1.class=”AutoAnswer”
    se.rt.ringAutoAnswer.ringer=”answer”/
    se.rt.autoAnswer.callWait=”callWaiting”
    se.rt.autoAnswer.micMute=”0″
    se.rt.autoAnswer.name=”Auto Answer”
    se.rt.autoAnswer.ringer=”0″
    se.rt.autoAnswer.timeout=”0″
    se.rt.autoAnswer.type=”answer”

     

     

     

    0
    rnbruce
    Participant
    Up
    0
    Down

    It would also be nice to set the caller id as Page or something that indicated that it is a page.  Currently it shows the party that is making the page.

    0
    jo-cpa
    Participant
    Up
    0
    Down
    Do you know how to add the Polycom firmware?  I don’t see it in the firmwares section nor do I see Polycom as an option to add in the Prov Temps > Brand dropdown.
    0
Viewing 6 replies - 1 through 6 (of 6 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.